3TB Drive not recognized

Ok, first of all I will explain how the 3TB Mybook Essential acts:

  1. It turns on

  2. Starts to spin and does normal sounds

  3. After 2-3 minutes it turns off and starts again


What I did:

  1. Changed the adapter - no luck

  2. Changed the USB - no luck

  3. Tried the My Computer>Manage - nothing shows up

  4. Tried Disk Management - nothing shows up

  5. Tried Lifeguard Diagnostics - nothing shows up

  6. Tried on another computer - no luck

Apparently the HDD is trying to connect to the computer, it does not see it and then it stops spinning. 

The HDD wasn’t dropped, or any damage done to it.

The PCB is ok, some parts are oxidated but it works fine.

The only thing that I haven’t tried it to connect the HDD via SATA to a computer, but since the HDD is encrypted I don’t see how can I recover the data if it shows up.

I have informations that I want to recover, so sending it to WD for a replacement won’t be an obtion unless I have the data back.

Any suggestions ?!


I recommend that you contact Western Digital for assistance.


I already did that. I was hoping that someone might help me over here. It’s obvios that they sent me to a date recovery company. If I send my broken HDD they won’t open it to see what’s the problem, they will just replace it.

So sending it before retrieving the data won’t be a solution. Has anyone tried to connect the HDD via SATA and see if the data can be restored from the HDD? I would try that, but I also know that they are hardware encrypted so I will probably see a blank HDD.

Make sure the USB cable isn’t longer than the original and don’t connect with a hub. Plug the power supply directly into the wall instead of a surge protector. You are right about the data being encrypted and unusable if you connected the drive via SATA. The encryption is handeled by the circuit board with the USB connector.


Ok, so I’ve tested with both cables and it doesn;t work. The adaptor is connected to the wall socket. The drive spins for 5 minutes, it stops, and it spins again. The white light is always on. 

The drive doesn’t appear in Dev Manager or anywhere else. The only option for me might be to connect it directly to the computer

If you open the drive it voids the warranty. Connecting the drive as a SATA won’t work if it is a drive that came with Smartware because it is hardware encrypted. Contact WD and they’ll probably send you a new power supply to try if your drive is still in warranty.


I’ve contacted them 2 days ago, and they tolm me that since the HDD powers on and it spins the problem is not with the PCB or the power supply.

Ok, I understand. But:

Would it seem logical to connect it via SATA and see if it is detected and then:

  1. Check it for bad sectors

  2. Try to reinstall firmware

  3. Connect it back to the enclosure and see if it works