My Passport: Won't mount under High Sierra

I have a new 2TB My Passport drive and it won’t mount under macOS High Sierra. I don’t see it in the Finder, from inside Disk Utility, or as a USB device in the System Information window. It also does not appear when issuing a “diskutil list” command from a Terminal window. Anybody know what’s going on with that?

I’m having the same problem. I have no idea what’s going on.

In Disk Utility click VIEW which is located top left

Already tried that, thanks though. I have “Show All Devices” selected.

Same problem here with 4tb

Your WD was working fine on Sierra or below versions, right? You need to contact WD and check with them if their devices have High Sierra support. Wait for the updates.

No, this was a brand new drive. I found an older drive last night and swapped cables – turns out I have a bad cable…

Same problem. Connection by FireWire, MyBook Studio 2TB. I sent a request for a resolution to the WD.
But, there may be a problem with the OS update High Sierra:

I had the same problem with a new drive on my Mac running High Sierra. When I tried to erase the drive using Disk Utility, I got an error, and then it wouldn’t mount. I couldn’t run First Aid or try to erase or partition without an error message. I connected the drive to another Mac that was still running El Capitan, and was able to use Disk Utility on that computer to run First Aid successfully and to properly partition the drive, which is now seen on both computers.

I am having the same problem, I just both the 3T a week ago and since than trying to fix lots of errors, one of them is trying to connect vis USB on my Mac book pro High Sierra.
anyone solved this problem yet?

I’m having the same problem as well with my 1TB. Updated all firmware/software and still no luck. It wasn’t working on my old OS, tried to update it to the 10.13.4 High Sierra but that didn’t solve anything. I’ve only had this drive for about a month. My passport won’t even show up anywhere on my computer but the light turns on and sounds like it’s running.

Well this is BS. I have a my passport that works on my old Mac thats running El Capitan, but it won’t mount or show up in disk utility on my new Mac thats running High Sierra. Since I’m ditching the old Mac and don’t see why I should still be using El Capitan, the drive has been rendered a useless waste of money. Not to mention disrupting my work while I try to figure this out. Time=money. If drives are going to simply stop working when Apple releases a new OS, maybe WD should offer a trade-in/voucher program to upgrade to a drive that actually works.

I had also the same issue with my passport Ultra disk. After updating to high sierra it stop showing in finder.
What I did is to download firmware upgrade from wd support website and install even it said is the same version it is installed. Before it I also installed wd discovery and from this app wd utilities. not sure what helped but I guess firmware upgrade was the file that helped - even I had some polish text encoding issues during instullation but using my intuition I manage to click proper buttons to install it. THan clicked disk utility and I’ve seen it was “mounted” so then I checked in finder and finally found my files :smiley:

1 Like

Same issue. I have updated firmware on a windows computer where they work, but again on OSX 10.13 they aren’t recognized :frowning:
12 days without my WD disks on mac

Hi guys, just wondering if any of you have found how to solve this issue. I have loads of precious info on my drive, which have not been in use for a week or so. Then I updates me passport for mac with new drivers because it was extremely slow. And now it’s now shown in my finder showing just WD unlocker. I didn’t create a password to the disk but still try to unlock it. When I unlock it nothing changes and I can’t extract info from my drive.

That really drives me crazy as I have work to be done using these files. Did WD officially explain what happen and what we should do? I’m afraid to loose my info so much :frowning:

Do you have the same?

Anyone able to find a resolution? Spoke with support 3 times, and it’s been useless. They essentially told me it was my mac and not passport, and that I need to do it on another computer. But in actuality, they are selling a product they claim is compatible with high sierra when it’s not.