Cannot add folders or files to my WD My Passport for Mac after High Sierra Update

I have been using this WD My Passport for Mac 2 TB EHD for at least a year with my Macbook Pro. I recently updated my Mac Software to High Sierra 10.13.1 and now I am unable to write to my EHD…add folders new files etc.

Anyone have any tips? My life is on this EHD and I have not had it long enough to break it. yet.


Just had the same problem and got it fixed on my system. Try this: Eject the drive. Disconnect the drive. Reboot the system. Reconnect the drive. Look at Get Info and the format should now read Mac OS Extended (Journaled) and you should now be able to create folders (at least it worked for me). Best of luck!

I just bought 2 new WD Passport drives. I tried initializing both of them with MacOS High Sierra, neither of the would format or even mount after I did that. I have another mac running Sierra, so I tried on it. They both initialized just fine on it. So the problem is with High Sierra using disk utility on the WD drives.