Upgraded to High Sierra (10.13) and drive disappeared

I upgraded my MAC to the latest OS X (10.13) and now WD Discovery can’t find the drive and after it runs, it causes Finder to crash. It seams something has changed between 10,12 and 10.13. Any ideas on what that could be that caused this and how long it will take to fix it?

Thanks for the help.


What file system is your hard drive formatted with? Did you check your drive in Disk Utility?
Does it looks “unmounted”?

Yes, I checked the drive with the drive utilities from both WD and Apple. I was working correctly prior to the upgrade from 10.12 to 10.13. I plugged the drive into a WIN 10 machine, and could see the drive, however, it indicated some damaged sectors. After I ran a disc recovery and repair program on the PC, I plugged it back into the apple and it was able to find the drive, mount it and then run a verify on the data between it and the Mac and the NAS storage this drive is backup to. A couple of errors found, but the files were replaced from the NAS and the Mac with no trouble.


Same thing here. I have a new WD 6gig internal Black and I had just loaded about 2T of project files. I just upgraded to the latest High Sierra on 1/29/18 and the drive disappeared. Doesn’t show up in Disc Utility. I have a 2nd drive with the same specs that I was going to use but now I’m concerned I’ll lose 3-4T of project files every time I have a system update. Please advise. Thanks!! Scott

I have been having the same problem today (1/30/18). Just upgraded to High Sierra 10.13.3 and the brand new blank 4TB My Passport drive is not being recognized. It showed up in Finder initially and then when I went to the TimeMachine app and followed Mac’s steps to reformat it as a Time Machine, it says the drive is not mounted. The error message says: “Unmounting disk. MediaKit reports not enough space on device for requested operation. Operation failed…” (This is a blank 4TB drive, trying to back up 1.4 TB of data, so space is not the issue.)

Repeated attempts to mount it aren’t working, and it also has similar messages when I’ve tried to erase it, restore it, mount it, etc.

How can I fix this… and soon! I need a back up. Thanks!

1 Like

I upgraded to 10.13.3 last night and I’ve been having the same issue since. Drive stopped showing up in finder. Rebooted the computer several times. Power light is on, but devices is not showing in finder nor WD Disc Utility.

When opening WD Drive utility, I’m also seeing the following message: “Failed to search for software updates. Server could not understand the Request.” Drive works fine when connecting to a friend’s imac that has not been upgraded to the latest version

I am having the same issue- I am now in the process of downgrading one of my Macs in the hopes that I can get the drive mounted again and continue working. Any help would be greatly appreciated!