My Passport Wireless SSD, can't see at MacBook

Good day.
I have a problem with my external My Passport Wireless SSD. I was switching from Win to Mac. On Win, I reformatted the disk to exFAP, after connecting to the Mac I can’t see the disk, not even in the disk utility.

When I connect the external drive to Win, the SSD light lights on. When I plug the drive into my Mac, the 4 battery lights light up like when I’m charging the drive. But the SSD light does not light up. The external drive works on Win without any problems, and other drives also work without any problems on Mac. So I need advice on the settings so that the drive turns on when connected to the Mac. Now it’s just charging. I tried connecting via USB-C and USB-A via the hub.

Here is a video:

For WDStaff, please read first. I wrote to support and they only sent me a general answer. that I should reformat the disk. As if they didn’t even read the problem.

Well thank you.

And one more thing, I already made diagnose test and nothing.

It’s possible that the drive is not properly formatted for use with a Mac. Even though exFAT is compatible with both Windows and Mac, sometimes the format can be corrupted during the formatting process. Here are some steps you can take to try and resolve the issue:

  1. Open Disk Utility on your Mac. You can find it in the Applications > Utilities folder or by searching for it in Spotlight.

  2. Look for the My Passport Wireless SSD in the list of drives on the left-hand side of the window. If it’s not there, try disconnecting and reconnecting the drive to your Mac.

  3. If you see the drive listed, select it and click on the Erase button in the toolbar.

  4. Choose a format that’s compatible with both Windows and Mac, such as exFAT or FAT32.

  5. Give the drive a new name and click on the Erase button to format the drive.

  6. Once the formatting process is complete, try reconnecting the drive to your Mac and see if it appears in Finder or Disk Utility.

If the drive still doesn’t show up, you can try resetting the drive by holding down the Power button for 10 seconds. This should restart the drive and allow it to connect to your Mac.

If none of these steps work, it’s possible that there’s an issue with the drive itself. You may need to contact the manufacturer for further assistance or consider getting a replacement.

Hi Jose,

Thanks for the response. Unfortunately, none of the above helped. In the disk utility, the disk is still not visible, it can only connect via WiFi. When connected with a USB cable, the drive still only starts charging mode, the drive starts charging the same way as when I plug it into the electricity. Exactly as in the video. Manual restart with the button didn’t help either. But the disk is functional, it still works without problems on Win. I also contacted customer support, but they didn’t recommend anything specific, just a general Q&A.