My Passport No Longer Detected


I have tried using the contact form on the Western Digital website twice now, but my emails must get sent to outer space or something because I never get a reply. Hopefully I’ll have more luck here.

I have a My Passport external hard disk (purchased in 2013, S/N WXU1CB1Z0083) that my MacBook no longer recognises. When I plug it into a USB port, the power light blinks white, but the drive does not show up in Finder. I have tried to find a solution to this problem, but I have not managed to find a fix. These are the things I’ve tried:

  • I have tried using a different USB port on the same computer (i.e. I have tried to connect via both USB ports on my MacBook). No luck.
  • I have tried to connect to my MacBook using a different cable. No luck.
  • I have tried to connect to a different MacBook and to a Windows computer. No luck.
  • I have opened the Disk Utility app on my MacBook, but the drive does not show up there either.
  • I have opened the Mac System Profiler and looked under USB, where I can see a device called My Passport 0748.
  • I have installed WD Drive Utilities. I can see the drive, but when I press the button for Drive status check, Quick drive test or Complete drive test, nothing happens.

Is there anything else I can try to fix the drive and/or retrieve the files on it?

Thank you in advance.


Is there any physical damage in your drive? It seems your device is severely corrupt since disk utility unable to recognize your drive. If your data is really important then you need to take your drive to Data Recovery Service Provider.

Thanks for your reply! No, there’s no (visible) physical damage. Any idea what caused the corruption, then? And is there nothing I can do at home to fix it? I can’t quite remember what’s on it. I used it mostly to back-up my laptop but may also have saved all of my photos on it. So I don’t really want to pay lots of money for a data recovery service only to find out it only has old laptop back-ups.

This may not be of much help but did you tried any data recovery tool on your drive?

I’m having a similar issue to Eva, however mine will show up on Disk Utility, but First Aid keeps failing and I’m unable to mount. How can I get this working again or is there a way to get the data recovery for free or is that costly?

Many thanks in advance.

No, I haven’t tried a data recovery tool yet. Any suggestions?

@ZachC1 Since your drive is visible in Disk Utility (though unmounted), there are chances of data recovery. You can try your luck with Stellar’s software as it supports data recovery from an unmounted drive. Trial link @Eva You can also try the suggested software, but I am not sure if it will work since your drive is not visible in Disk Utility.

The software doesn’t work for me, unfortunately. Thanks for the suggestion, though!