WD Passport No Longer Showing Up on MacBook (But shows up on other Macs)

Hi folks, hope you can help.
I have a WD Passport, which has been working fine on my MacBook with zero issues.
Suddenly, my Passport is no longer identified by my MacBook, and it doesn’t show in the Finder pane.
I’ve tried the following:

  • Edit preferences to show items under general and sidebar
  • Checked drive in other Macs and it works fine
  • Attempted using Terminal (diskutil list) but nothing showing as external
  • Searched it using Disk Utility, but nothing is showing
  • Reset NVRAM
    Other USB devices (memory sticks) in USB slots, and they work fine with no issue.
    As mentioned, I’ve tried the Passport drive in a different Mac and it works fine, but for some reason it appear or work in my MacBook. It’s really frustrating, as it was working perfectly and I’ve done nothing different and randomly its decided to stop being recognised in the MacBook. I use the MacBook on a daily basis, with the Passport working fine and I went on holiday for 2 weeks and tried to use it on my return and its no longer recognised in the MacBook (but in the Mac).

Any help or suggestions would be most appreciated, as its driving me crazy not being able to do anything on the MacBook.

Hi @MattE76,

External Drive Not Detected by Windows or macOS Quick Assistant: Resolve External Drive Not Detected by Windows or macOS Guided Assist

Please contact the WD Technical Support team for the best assistance and troubleshooting: