Can not see my passport wireless through USB

Worked the first time to transfer some movies and now it is not showing up in my mac?..any suggestions?..

Welcome to the Community.

Is this happening with any computer, or only on your Mac?

1 Like

Thanks; I tried already with my mac and windows 8 and XP and I can not see the drive with the usb cable; still on my mac I can connect and use dashboard but transfering files using wifi is extremely long…do you think I have to reformat the disk?

asnyc75 wrote:

…do you think I have to reformat the disk?

No! In fact, **bleep** No!

Why do people think the first thing they should try is to reformat disks, or reinstall Windows, etc. Those sorts of actions should be the LAST thing you do. Understand the problem, and then fix it. A reformat is unlikely to help at all, unless you have already reformatted the drive to some strange format.

So, you can connect to the MPW via wireless and use the App to manage the it. Great, so it is working. But it is slow, so that could well be your network, not the MPW, although of course a wireless connection is much slower than a USB 3.0 connection.

I would try these things first;

Completely power the MPW down, then connect it to your PC using the USB cable, and then power it up.

Did that work? No?

Do a Manual Reset of the MPW. From page 47 of the User Manual;

  1. With the power ON , hold down the Power and WPS buttons at the same time for around 10 seconds until the drive reboots and the Power and Battery Status LED flashes white.

  2. Wait until the Wi-Fi LED is blue before reconnecting.

You won’t lose any data when you do this, but you will need to re-enter settings such as passwords and such.

Did that work? No?

You could try a System and Disk restore, as per the manual. But backup yor data first! Not that you may need to update the firmware to the latest again after you do this. Make sure you update the firmware before trying the USB connection again.

 If none of the above work, you may need to raise a support ticket with WD.

1 Like

Thank you so much for your help; after I made a disk restore the disk showed up on my desktop. I spent 2-3h trying all the things you mentioned before. What is really sad is that after tranferring all these movies from my itunes library I can not watch them becuase of the DRM permission from apple…Do you think apple is planning to allow us this playback again? I downloadd M4VGear to remove the DRM but it is not ideal…

Good that you got it working. Bad that your movies have Apple DRM.

I don’t know if Apple, or the rest of the media industry, will ever see the light when it comes to DRM. Probably not.