My Passport Wireless doesn't recognize on Mac

I just updated the latest Mac iOs El Capitan 10.11.5. Previously I can read My Passport Wireless, but after the upgrade it doesn’t recognize anymore on my computer. Does anyone got the same issue like this?


Shall I upgrade the latest Firmware from WD or any software that I need to install from WD to resolve this issue?
The HDD is in prime condition just happened after the upgrade.

Got the same problem. My Macbook cannot recognize MPW using USB cable. The white light kept on flashing but the device did not come out in MacBook. Please help…

Hi Rose_Viernes, mine, after a while the light flash turns white constantly, but nothing appear on my mac… No drive recognize. Do you get the same?

Just want to clarify:

  1. I tried to upgrade the Firmware of My Passport Wiresless, but since it didn’t recognize by my Mac so I can’t do much things.
  2. I tried to upgrade the Firmware through SD Card, but it doesn’t work too… I don’t find anything as said on the manual it will blinks during the update via SD Card. But nothing happened.

Can WD Help me what shall I do about this?! Do I need to upgrade the firmware one by one from the previous version? I never upgrade it’s firmware since i bought it.

Yes, I got the same problem. It does not appear in Mac using USB cable. But it will appear when I use it as wireless. What do we do with that?

I am still finding out the solution for mine too… I can’t even access with my wireless… I don’t know why…

I found a solution. I went to my friend house who got Windows. I plugged in the HDD, it says need a repair so I repair and fix by softwares. Then it can be detected. I eject from windows, now works again on my mac. Just like normal… Hope it helps. Well This is the only way I can find so far :slight_smile:

My HDD is back to live again. Hope your HDD too… But this things WD Need to do…

Will try that…thanks for the info :slight_smile: