WD My Passport Wireless not detected by mac when connected via USB


#1

Hello,
I think that this is a common issue. I am using My Passport Wireless for the first time on macbook. I can access it fine through wireless connection, but I am not able to use it with USB.

  • I have tried changing the the cable, and tried that on another macbook, and still, it doesn’t show up neither on disk utility nor finder
  • I have tried rebooting (holding power and wireless buttons, while on, for 10 seconds and then waiting until power turns blue and connect, did not work.

. My macbook’s OS is Yosemite (10.10.1). One thing to notice is that when I connect it via USB, the power LED keeps flashing, which, according to the manual, means that it is charging.
So, it is charging but not being detected!

Does anyone know what to do with that?


#3

In the MPW’s UI, is the Drive lock feature turned on? If it is, turn it off.


#4

Thank you very much, Myron. That solved the problem.


#5

Excellent! That feature is so no-one can just grab hold of the MPW and connect it to their computer and access it. The option acts like a USB data blocker so anyone wishing to access your MPW would have to have the necessary WiFi password. You can also connect it to anyone’s laptop just to charge it.

I think you can toggle the drive lock from the iOS and Android apps, but I’m not sure about that. I’ll have to have a look.

The MPW is not one the most secure gizmos and I don’t think it’s supposed to be but it is darn useful when it comes to taking a copy of everything on an SD card once you’ve filled it up.


#6

hi. i;m having the same issue…what is MPW pls ?


#7

I’m having the same issue, when I try to connect the MPW tp my mac it does not recognizes, the wifi turns off and power led blinks, I tried to turn off my Drive lock but nothing changed