Wireless wifi not picking up on mac high sierra

wireless mypassport issue - worked fine since purchase but now its wifi signature not showing in available wifi devices. shows green power and blue wifi lights. have restarted several times. also can’t get to dashboard without accessing wifi drive. no usb port - am i screwed?

See if any of your other wireless devices can see it. If NOTHING can see it, try doing a reset per instruction manual.

thanks for answering - if you mean holding both buttons down until it resets; yes several times. i also cannot see the drive on iPad or iPhone.

Hmm. Well, it’s always possible the WiFi interface in the MPW has failed – best bet if that’s the case is to unload the data via USB and replace the drive (RMA it if still under warranty).

unfortunately this model only has card reader, no usb port - mistake on my part for sure. any recovery options available from 3rd parties?

There’s no My Passport Wireless that DOESN’T have a USB port. That’s where you charge it. :wink:

strangest usb i’ve ever seen - pic of power plug and socket attached.IMG_0477

That’s a normal USB3 micro port. :wink:
Instead of plugging the other end of that cable into the charger, plug it into your PC and voila! There’s your files!

ok - i sure feel stupid! did as suggested and plugged usb into my mac - still doesn’t show as an active storage device in my finder or anywhere else. both lights still solid blue. was really hoping this would work. i can hear it whirring but nothing shows.

Heheh… Don’t feel dumb. Two days ago I stubbed my pinkie toe on something I saw right in front of me!

Hmm. It should not show two lights when connected via USB. First, don’t power it up when you try to connect via USB. Connect it when it is totally powered off.

Any different?

it shows the battery full and wireless active whether i plug into a-c or usb port on mac. then pushed power button that flashed white and then plugged into usb on mac. power is now solid blue and wireless light now not lit but drive still doesn’t show up on mac finder.

Ugh. My guess is the thing is dead.