My Passport Ultra doesn't Work on 3.0

I’ve bought a brand new “My Passport Ultra 1TB”, but I have a problem: web I connect it into a 3.0 USB port and i try to’ transfer some files into the HDD, the process just freeze around 2%. The PC works, but the copying process stops and doesn’t go on.
This happens both on my frontal and rear USB 3.0.

If I connect the HDD to a 2.0 USB everything works fine, but really slowly (of course).

I tried to update all the drivers, to delete and install them, I tried to disable the auto-shutdown of the HDDs in the power-saving settings.

BUT if I try another 3.0 HDD (another brand), it Just works fine on my USB 3.0!!!

I’m gong crazy, if is not the HDD, should BE the USB? But it seems isn’t the USB neither…

Help!! And sorry for the bad english

Hi there,

Try to use a different USB cable to see if the same happens, also you can try the drive on a different computer. I would say this is a driver issue, but you can also try to check the drivers for the USB 3.0 controller just in case…