WD My Passport Ultra wont work on USB 3.0 but will work on USB 2.0

Exactly as it says – and happens on any equipment (tried it on several desktops and laptops) so it’s not isolated to a particular computer. 

Thoughts? Ideas? 

If you have one, I’d try a different cable in case your one is knackered on the USB3 connection.

Already tried that. My cable works with my coworker’s Ultra, but my Ultra still won’t work even if I use his. 

And yeah, his Ultra works on the USB 3.0 ports on the same desktops and laptops where mine wont work. 

Sounds like one for  WD tech support, and maybe an RMA job if you need it on USB3.0 ports. 

Probably something gone screwy with the drive hardware or firmware perhaps. You could check the firmware is up to date, but if so make sure that you have backups of any critical data on the drive first.

Has the latest firmware. Passes all the tests using the WD utilities (provided its plugged in to a USB 2.0 port)-- and sadly, yes, I do need it to work with USB 3.0 as we got equipment that only has 3.0 USBs

I even formatted it to NTFS to see if that would make a difference.

I guess I’ll have to RMA it.