My Passport Ultra 1tb flashing light of death

I have a my passport Ultra 1tb, purchased boxing day of 2014.  I use this literally every day to store documents for work, it sits stationary on my computer plugged into the same USB port everyday.  This morning when I woke up and started to work I continued to use a file still open on my computer saved on the passport and an error message came up.  Stupidly I didn’t really pay attention to the message.  I shut everything down and re-booted only to find that my passport no longer comes up anywhere on the computer.

There is a white light in the front of the my passport that blinks frantically for a bit and then turns solid however it never appears for me to access on the computer.   I have tried every USB port, as well as two other laptops.  I took it to a geek squad guy who says also nothing comes up and when he tries it with a new cord that also does nothing.  What happened and how do I make it work again?  I have years worth of work documents saved to this thing :s

Someone please help 

Hi and welcome to the WD community.

On this case i recommend contacting Support for further assistance on this matter:

I hope they can help you out with this issue you are experiencing.

you may have a problem with the hard drive on the firmware level, this explains it:

too many bad secotors.jpg

You can use “GetDataBack Simple” to get your data with the directory structure intact if it is showing up as a RAW partition. I was also frustrated and tried several other software but this only worked for me. It was totally worth the 80$.