My Passport Ultra finally gave in

I bought a 2TB My Passport Ultra 4 years ago. In the 4 years, the hard drive was always treated with extreme care - never dropped or bumped - it wasn’t even transported anywhere!
Today, it gave up on me taking with it 2TB of movies and series.

When I plug it into my PC, the light flashes continuously and the disk turns - there is a tiny click from the drive every minute or so.
The computer recognizes that something has been plugged in but cannot access the drive. It doesn’t show up in Disk Management either.
I’ve tried different ports, cables and a different PC with no luck. I’m running Windows 10 and have the correct drivers installed.

Have I actually discovered the true lifespan of a WD drive?

Hello, MoeARPeer,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support

I’ve tried everything that Tech Support would tell me to try. And the drive is out of warranty - so I don’t see the point.
I’m not trying to get anything out of this. Just sharing my experience.

I’ve had my 1 tb passport for a year and a half and it pooped out on me it seems. I’m getting “application not found” and have tried tons of different things.

My drive also makes 2 or 3 clicks/cherps/beeps every minute or so for 2 or 3 times then stops. Every now and then it will do it again.

The other error I get when I try to initialize the disk is “the request could not be performed because of an I/O device error”

Can’t you send it to WD under warranty?

I don’t think their warranty recovers the data :frowning: