My passport for Mac not being recognized anymore

So I connected my passport for mac to my macbook computer (OS X El Capitan) today, it opened fine. I tried watching one of the movies I have on there, it started, but an error message suddenly appeared, saying it couldn’t read the file (which was strange because I had just watched the same movie not a week ago). So I decided to eject the drive, restart the computer and try again. It just made everything worse. When I plugged it in again, I got a message that the drive was not recognized by the computer. I insisted a few times, now even this message isn’t popping up anymore.
I read through a few topics here which said to open disk utility and try first aid. But, although the drive is showing on disk utility, it’s greyed out. I clicked on first aid, but a few seconds later I got a message, it had failed.
I downloaded WD’s utility, tried running the quick and complete tests, but both failed.
I tried using another cable, I tried connecting it to another Mac; nothing.
I don’t know what else to do, do you guys have any ideas?
Thanks in advance!

I was just looking for an answer to the same issue. I have had My Passport for a couple years now, to use as the Time Machine Backup for my Mac. We moved, and it has not connected since we moved, and will not show up in Finder even though it is showing in disk utility. I think it might be full, and that is the problem, but I can’t access it from Finder to check and see/delete old files.

Do you know if yours is full? If so, that could be the common theme…

Not really, it is going on full but there is still plenty of free GB on mine

Hello there, I have the same problem and have contacted the WD support. I hope they answer soon and that there will be a solution to the problem.
I disconnected my WD passport studio from my iMac OS X 10.9.5 three weeks ago and wanted to plug it in today. It does´nt show on the Mac and it does´nt make any noise or show any sign of activity. I am very distressed because it is a backup of all my photos.

I am having the same issue! One day it was working fine, the next it gives me the same error. Then I run first aid, it says completed, but no change. All the storage is pink, which is like yours “grayed out” it is surely not even close to being full. I contacted Mac support but they said nothing was wrong with my computer or settings to cause this. I’m hoping we get answers, my whole life is on my external!

I contacted WD support, unfortunately they couldn’t help much either. They gave me two options, reformatting or trying data recovery. Reformatting would of course erase everything, but it might save the drive (no guarantees, though). If I wanted to try the recovery I was to seek out some free data recovery software on the internet, since they don’t offer this service (apparently, it’s expensive). So, yeah, not sure what I will do, but it doesn’t look good guys, sorry :frowning:

What websites has free data recovery?