My passport does not get recognised by mac?

i can’t see my passport on my mac ?


in order to better assist you, could you please provide more information on this issue for example, the Mac OS version and if you get an specific error.

I’m having the same problem, support guy didn’t reply to me. So I’m looking here.
Sorry its not a reply really. Just hoping for some help too.

I’m having the same issue except when I first hooked the drive up it was recognized. Then I went through the software setup but now it acts like it’s disconnected. I’m on an older system and got this drive to back up before going to El Capitan. I have never used the software on HDs I have usually just reformatted and then went through time machine.

The drive is a passport for mac 1 TB USB 3.0

My system is a mid 2009 iMac still running Snow Leopard.

Edit: This drive does not show compatibility with Capitan on the box but I’m assuming that won’t be an issue when I upgrade.

Another Edit: Just tried to reformat immediately after hooking up and it starts then the drive powers off

I am having the same issue. I just bought My Passport for Mac today. I plugged it in, it asked me if I wanted to back up and it ran for an hour doing its thing beautifully.
Then it stopped and said it had an error and if it continues to run a disc utility.
It failed. I ran the first utility it offered. It passed. Then it stopped running. The Passport icon disappeared and it was no longer listed in Finder.
Every time I plug it in, the icon disappears after a few seconds.
I am on a 2009 Mac, running Yosemite.
HELP !!!

I’m having the same issue with My Passport Ultra.
All was functional until my last b-u on Feb 20 2016.
It is plugged in, indicator light is flashing but it is not visible to Finder.
Any thoughts…

PS: I’m on a MacBook Pro (Retina 15" Mid 2014), running on OS X El Capitan vs 10.11.3

hi there, again i am not being helpful here but i am experiencing the same problem…nothing appears in finder when i plug my Passport Ultra in anymore. it is as if it does not exist/function. i need it to work ASAP because i need to transfer a few things from it to my mac.

i have a 2011 mac using yosemite

any help would be seriously appreciated


This is the reply I received the other day from WD concerning my problem. Although, when reading some of the comments I find it questionable that it is a firmware problem vs. a software or a compatibility issue with Mac.

Have any of you contacted WD. Was your problem resolved or have you received a similar reply to your query.

"Thank you for your reply.

The unit you have by default is formatted for Windows. Did you formatted the unit before using in a MAC? YES
If you did and the hard drive is no longer accessible, and all trouble-shooting solutions have been exhausted, the unit is defective and must to be replaced."