My Passport for Mac - folders show up but no files sometimes, have to force eject

I have a My Passport for Mac and it has been working fine for over a year or so. Then, all of a sudden one day, I could see the folders in there but no files were showing. I tried to eject it and it said one or more programs were using it and I had to force eject it. I plugged it back in and I could see everything fine, tried to eject it and it ejected with no problems. After some time has gone by, this keeps happening over and over. It will show all my files just fine when I plug it in but after some time, files are no longer showing and I have to force eject it. I ran the first aid through disk utilities and everything was fine with the external hard drive. I got another My Passport (this time not for Mac so I formatted it for Mac) and moved everything to that external hard drive to use instead and now that one is doing the same thing as my My Passport for Mac. Could this be a corrupted file causing a problem or possibly Mojave causing issues? I have no idea what to do other than possibly get a whole new external hard drive from a different company to see if that works.

Need some info:

What Mac system?
macOS version?
How drive is formatted?

Maybe one of the ports has issues.

@DonaldKepler thanks for responding.

iMac (2017)
MacOS Mojave
The Passport for Mac is Mac OS Extended (Journaled) - that’s how it came.

Try this — if the drive says that files are in use however you know that no files are in use then Go to Apple Logo on top left << Force-Quit << Relaunch Finder.

Another option could be, when you know that the drive is showing all the contained files correctly then waste no time to copy all the data to your Macintosh HD or another drive. When all the data is copied successfully from the troubled MacOS Journaled drive to another drive; go to Disk Utility and erase the drive with APFS. Copy back few files to check if the APFS drive is behaving correctly. I think APFS format should help solve the issue but backup your HFS drive properly before applying any method.

Thank you so much for your help. I ended up formatting both of the external drives, partitioning the Passport for Mac to only use one partition for Time Machine and the other for saving files and formatting the My Passport and they are both still doing what they did before… working fine but then after they are plugged in for some time, won’t show files and I need to force eject because it says one or more programs are using them. I had originally formatted the My Passport as APFS so I reformatted to Mac OS Extended (Journaled) and reformatted the My Passport for Mac when partitioning to Mac OS Extended (Journaled) as well because that’s what our computer repair store guy told me to do since I was using it for Time Machine. What I’m trying to do is save files to these external drives then unplug them soon after. We have another external hard drive (WD My Cloud) that doesn’t have any issues at all that I wirelessly use.

I did happen to notice that these issues started after my husband added more RAM to my iMac. I didn’t think about that timing coincidence but he brought it up so he changed the positions of the RAM to see if that would help and it didn’t. The next step is to totally take out the 4gbs of RAM and only have the 16gb in there. Do you think that would make a difference?

Thanks again!

I have this exact same problem with a 4 TB My Passport drive that I have been using for a while. It is very frustrating.

I have noticed that this is happening whenever the Mac goes to sleep. When it wakes the drive can be seen but none of its contents are available. I’m running Catalina on a 2018 Intel Mac Min.

Bumping topic. Has any body found a fix to this? I’ve own this drive for almost 2 years now and this drive continues not show any files even though it’s connected. I’ve seen some suggest turning off sleep mode for external drives, but that didn’t fix it. I see some folks have completely formatted their drive but it didn’t work, so I would rather not do this as well. I have noticed that the light on the drive is constantly blinking whether it is working and able to access my files or the files no longer show up. I’ve had other external hard drives plugged in all day/week and do not have this issue. So tired of force ejecting/re-connecting this drive. I’ve only used about 1.9GBs as well, so it should not be a space issue. I am using the USB-C to Thunderbolt bolt connection. iMac is macOS 10.15.7.