My Passport for Mac - Not Showing on my iMac... Please Help!

Hi all,

I would be grateful for some help.

I have a WD My Passport for Mac 1GB external hard drive.

The drive has been connected to my iMac for the past few months… when I tried to access a file this evening, all the folders were there but all the files were missing. There was a message saying the disk hadn’t been ejected properly - but I didn’t take the USB cable out!

I have tried taking the USB cable out and putting it back in, but the drive doesn’t show on my iMac. (Also tried it on my Mac mini, but no joy.) I got another message saying: “The disk you inserted was not readable by this computer.”

I have it connected to my iMac just now and there is a steady white light on the drive and it’s making a noise. It is also currently showing up in Disk Utility and WD Drive Utilities - passed the WD status check but failed the scans.

Can anyone please advise what I can do to access my files?

I’m running the latest version of El Capitan - 10.11.4.



It is possible the partition is corrupted and you will need to format the drive in order to use it again. However, If you need to recover the data on the drive then formatting is not an option since it will delete everything on it. I recommend you try recovering your data using a data recovery software. Try searching the internet for a data recovery software and try to recover your data before you try formatting the drive.

Hi Hamlet,

Thanks for your reply. I do need to recover all of my files from the drive so I’ll see if recovery software works.

Thanks again!