My Passport Drive not accessible

Hello, I have been having some issues with My Passport to drive for two months now. Copying files into the drive would sometimes hang. Then, it continues after 5-15 seconds. Today, I was copying files into it. They did the same thing.

Though, when I finished copying the files, I opened three files. The first and second files opened fine. Though, opening the third file caused my Windows Explorer to hang. I tried safely removing the drive but it would not let me.

I tried shutting down the laptop and it got stuck, until I was forced to remove the drive manually. Then, the laptop shutdown OK. I tried plugging my hdd back but this time I had real issues.

I have heard the USB plugging in sound, and I hear it spinning up, also the drive shows on the list of devices to safely remove. The drive’s LED flashes fast non-stop. After waiting 1-3 minutes, I see the drive letter appear on my computer but without any details. When I double click, the explorer hangs.

I can see the drive on device manager. Though, when I open diskmgmt.msc, the window just freezes without showing any details.

Did anyone have this issue before?

2 Likes

I am currently having this issue as well. My issue is identical. I tried going into Computer Management>Disc Management but it just locks up when the external hard drive is inserted. I am really hoping that the drive is not ruined.

Try getting a new USB3.0 cable from a good brand. I cannot find any brand USB3.0 cables around me to try and Corona is restricting my movement. I cannot go far. Let me know how it goes for you.

I’m sorry to hear about your issues with the WD My Passport external HDD! I’d recommend you to try using a different USB cable when connecting the drive to your laptop or computer.

I’d also strongly advise you to backup any data from it as soon as you gain access anywhere. You should also try uninstalling & reinstalling it as a device from Device Manager.

Here is how to do it: https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc725782(v=ws.11)?redirectedfrom=MSDN

How does it appear in Disk Management? If you are able to see it there, you should try assigning a different drive letter to it.

Hi all,

I have the same situation about a week ago. What i had done are is to run chkdsk (saw some bad sectors/unreadable but i can see it able to detect the files/folders) and also uninstall my USB driver. Still success. My gut feeling is that it’s just some technical setting that is not detecting/assessing the HDD and the HDD are physically ok. And this the second time it happened to 2 different HDDs. Anybody have solution for this?

I have six products now that I cannot not access all of the sudden and there are no answers or help. Please someone tell me how I can get MYbooks and MyPassports to be recognized and to be able to use my paid for devices?

Hi,
I am also facing same problem with the 3TB HDD.

HDD appears in Drive(E:). But windows explorer hangs and not able to access the data inside, Disk Management Hangs, Diskpart hangs, not able to remove the hard disk properly.

I am having many photos in that taken for the past 5 years, i cant miss those. please share if you guys got any solution for this issue?

Thanks,
Karthick

I contact WD for a replacement cord and they haven’t sent it to me yet. My Drive is still under warranty so hopefully they are not trying to stall so that they don’t have to do anything about it. Would be able to give a list of “good brands” for USB3.0 cables. Even the website says that they no longer offer support for this device.

Any news on this?

1 Like

I had this problem with 1 3TB WD drive… drive is conked, though not dead. It’ll appear slowly after a long time (say 5 minutes). You may still be able to copy data off it, but it’ll be veeeeeery slow, like 50KB/s

Did you try purchasing a new USB cable?

Yes. problem is with the drive, not the cable.

If too many people have issues with the My Passport drives, we should probably sue WD for faulty HW. I have used my drive for backups only, and shelved it. It was not even a dedicated drive.

No response from WD yet. I haven’t received a replacement cord yet either.

I had the same issue. Finally i find a solution, i hope it will work for you.

Step 1. Press the Windows key and type cmd.

Step 2. Right-click “Command Prompt” and choose “Run as administrator”.

Step 3. Enter the following command:

chkdsk drive letter: /f

It will be like chkdsk H: /f

The most important thing that you should know about this solution is: WAIT. I am telling you this because first couple of times that i tried this, i didnt wait, just quit the cmd, thinking it isnt working, because anything happens on the screen. I was wrong. Today i ve waited long enough, and finally solved the problem. Please just wait.

P.S. I have 3 tb my passport and it was listed on device manager but not on disk management. When i tried the open it, windows explorer froze. When i unplugged it, i got the “The parameter is incorrect” error message.

I have tried the chkdsk approach. It took chkdsk 1.5 hours to display the message “The type of the file system is NTFS.” and 1.5 more hours to display “Volume label is My Passport.” Finally, it reached the “CHKDSK is verifying files (stage 1 of 3)…” phase. It took it 1h to process a single file record out of thousands. So, I stopped it in fear that the drive would be permanently affected. Can you describe your experience telling us how long it took you to finish chkdks on your drive?

Thanks.

It took less than 2 hours. Only 250 gb used, max file size 2 gb, mostly photos. Maybe it is because of the computer performance . I had a brand new notebook.

Thank you so much for taking the time to reply to my question. God bless you. I give up for now. I am afraid I will damage the drive. My drive is full 3.5TB filled.

Thank you, i hope you find a solution too.

Since chkdsk can take a long time, be sure you modify your PC/laptop Sleep time. Type Sleep in the search window at lwr left. This is especially needed if the cmd is running overnite and you are not touching the keyboard or mouse. You can turn it off.