WD My Passport USB 3.0 - not accessible PLEASE HELP!

HP Pavillion 15 Notebook
Windows 10

WD My Passport USB 3.0


I cannot access my external drive (WD My Passport). As I was using photoshop,
editing a file from the external drive, when photoshop lagged, the drive didn’t show up
in my laptop. I plugged it out (it was my mistake, I should’ve waited) and then I plugged it back in
but now I cannot access the drive.

It says, “F:/ is not accessible.”
The volume does not contain a recognized file system.
Please make sure that all required file system drivers are loaded
and that the volume isnot corrupted.

Also, “F:\ is not accessible. The parameter is incorrect.”

WheneverI tried to click safely remove,it doesn’t do anything. Lags again.
And also the label of the external drive changed to - My Passport 0740…It says, “Eject My Passport 0740 - Local Disk (F:)”. I had my name as its
label before.

I tried plugging it in another laptop but it’s still the same problem. It shows up as, “Local Disk (F:)”. Whenever I click
it, the windows explorer lags.

I have many important files inside that drive, and I really need them for work.

Please, could someone help me find a solution to this problem… Your help will be much appreciated!

Hopefully you just scrambled the files directory, so maybe scanning the disk for errors and fixing them will help. Try it on any Windows machine with the drive connected… Using Windows File Explorer (used to be My Computer, etc.) locate the drive that is connected to computer and right click on it. Select Tools tab and from there find "check disk for errors " and run the check. This may fix it. If you don’t see the drive being connected to your computer, it may be in worse shape than I imagine.

You may have posted this in the wrong forum, this is a forum for the WIRELESS drive, not a plain vanilla Passport sort of drive.

Hi mike27oct, thanks for replying. Sorry I didn’t know that I should put it in another forum. Not quite sure where, but I placed it on WD external drives a minute ago.

I did try using windows file explorer, but everytime I clicked on the drive the explorer lags and I couldn’t do anything about it. Does the CMD chkdsk method work for this? If so, how do I do it? Do I need to do something first before I perform that method? I’m afraid I might lose data if I do it right away.

I tried using a recovery tool (yodot recovery tool) but they only scan it and you have to pay to recover the files. Can you recommend any free recovery tool?

Thanks a lot…

I really need those files… :frowning:

Sorry it did not work for you. Let’s see if anyone else has any ideas to try. You might want to contact WD Support; this is a user forum.


You can try the below link to recovery your data and it consist of top 19 best recovery software.

My passport ultra 2T with passcode
Windows 10

it was working fine. one day it fell from my hand so i connect it and tried to put the password it start telling me invalid password. i tried to recover my data using wondershare it didnt work so i left for 5 month wothout trying any thing now i try to access it again it saying this driver is not locked to unlock a different WD driver please open the WD DRIVER UNLOCK CD associated with the desired drive and the run the WD DRIVE UNLOCK application to unlock the drive.

my driver is appearing on the system but is showing 0GB and no format no nothing.

Please i need to recover my files and to re-use my hard drive. Any ideas?

I have similar thing like this:
suddenly I can not access my drive.
I try using USB windows PE and I can access my files and folder.
I try to back up all my files to another drive. and back to my last OS.
I stil can not access my wd passport drive,
I try to format it and copy all my backup drive to my wd passport drive that has been formated.
And everything work well.
Hope is helpfull.