My Live Hub turns off at startup. Please help me!

Hi everyone, don’t blame me because I do not speak much English. I’m French.

I have a big problem with my hard drive. When I starts it crashes stating that the update is incomplete. I tried to update via USB but is always the same problem. The update does not even work. Worse my hard drive is now invisible in my network when it is connected directly by Ethernet cable. Can someone help me? Thank you in advance.

Well, if it did an incomplete firmware upgrade and wont upgrade via USB, then you can try THIS.

This may or may not work, all I can say is that it did work for at least one person who had the same problem.  And the worst that can happen is that you’re stuck in the same position.

Thank you Tinwarble I’ll see your link. I’ll tell you if it worked for me. Thank again.

I’m really in the **bleep**. How do I rename the file? On 02.07.18? I did it and the result is always the same.

Are you saying that you did change the .ver file to 2.07.18 or are you asking how to change it?

If it’s the later, download the firmware, then unzip it to your PC.  You will see 4 files, open the file “wdtvlivehub.ver” with notepad, then change the line:

VERSION='2.07.17 LOCATION='wdtvlivehub.bin’PKG_LOCATION='wdtvlivehub.pkg’ROOTFS2=‘wdtvlivehub.bi2’

To something like:

VERSION='2.08.17 LOCATION='wdtvlivehub.bin’PKG_LOCATION='wdtvlivehub.pkg’ROOTFS2=‘wdtvlivehub.bi2’

Then save it.  Then copy all 4 files to the root of your USB thumbdrive and then follow the directions on the linked post.

Thank you for your help but I still have the same problem. I think my device is damaged.

Heatmakers, if you tried all the advice given here and still, the device is not working, them contact WD, if your WD TV is under warranty, and submit a RMA.

@Heatmakers i have the same problem.

WD TV starts - blinking then off :frowning:

I thought I was the only one with this problem. You have solved the problem? If so then can you give me your solution? Thank you in advance.

Yes I’ll do it after exhausting all options because I have data in the hard drive and I want them back.

Hi Everyone,

I had the same problem and the only solution was:

Works perfectly without any issues.

Kind Regards,


This might help folks out too…

 Interesting how WD hasn’t really done much about the issue. So far mine’s been fine so I guess I’m lucky but I rarely use the switch on the hub.

flhthemi wrote:


 Interesting how WD hasn’t really done much about the issue…

How do you know what WD has done and not done?

You know tony, I really don’t know what they have done about it. Perhaps YOU can enlighten us all…

flhthemi wrote:

You know tony, I really don’t know what they have done about it. Perhaps YOU can enlighten us all…

I would assume that they have updated their manufacturing process but then again maybe not… Just because you or I don’t know does not mean that WD have done nothing.

Same problem here!!!

Crappy support WD!!!

I’m gonna try to contact those guy’s!

Now my problem is solved but this is a disaster for those who lack some handy scills and don’t know what a PCB is!