Failed Firmware Update - Hub no longer functional


Which firmware?


Former firmware not precisely known, started with a 2. Device purchased on the 8th of October 2011. Tried to upgrade to firmware 3.01.19.


What happened?


Hub is not and has never been connected to a network. I tried to update the firmware manually with an USB stick and followed  the instructions on the WD website to the letter.


The USB stick contained the files md5sum.txt, wdtvlivehub.bi2, wdtvlivehub.bin, wdtvlivehub.fff,, wdtvlivehub.ver in the root directory.


 The "Update Firmware" option appeared as described, and everything went as described until after the information "rebooting" appeared. After that, the device only showed the WD logo, and nothing happened for over two hours. The device has never shown the usual menu since then and is totally inaccessible.



What were you doing?


See above.



Does this happen every time?


Onetime firmware update failure, up to now fatal.



What hardware and media were you using?


Serial number of the hub is [Deleted]

Model is WDBACA0010BBK


The hub is connected to a NEC projector via component video and to loudspeakers via composite audio.


- Did this happen with previous firmware?

Does power cycling the unit solve this?





Does resetting to factory defaults solve this?


The reset button does not seem to work in this state. Reset via menu is inaccessible.



Have you tried this on other devices?



Nikolaus1, maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support


I have been having WDTV Live HUB since it was released, I have updated several Firmware releases, I have rolled back several times and NEVER had any firmware issues, But I just wanted to let community know that for the first time Firmware Version 3.01.19 did cause a bit of a scare for me.

BTW, I always update firmware using USB stick method just like the user reported here I also saw the exact same symptom and my heart stopped beating when I attempted the Firmware Version 3.01.19.

My symptoms were similar wherein new firmware was detected, The WDTV Live HUB unit acknowledged the firmware update process and rebooted and was stuck at the WD Logo for more than 30 mins (My heart really stopped) But I could not take it anymore so, I bite the bullet and pulled the power cord and power cycled the unit, and luckily for me the FW update process resumed after that.

Just to let the community and WD Tech Support / developers know that there is obviously something not right with the reboot process for some devices out there, I had reported this symptom before wherein it take longer than normal at WD LOGO screen before… and the COLD reboot and WARM reboot has some differences.

See this bug report

Hope this will give the WD Developers some clue.

Thanks for reading this report.