My cloud not found on home network

My cloud device dose not appear on the wireless network.

MyCloud lights:

Front panel LED - blue steady

Back panel LED - green flashing above, orange solid below

What ive tried:

  •  have looked for device on 3 pc’s, not found. Tired with another router, not found.
  • Removed the power for so long.
  • Reset used for 4sec, not found, then for 40sec, not found
  • Downloaded “wd discovery” unable to find device
  • Turned off firewall
  • Changing ip address to static via router interface
  • Carnt use WD desktop programme
  • Tired to update Firmware but carnt use WD programme, as the programme carnt find the device and i dont know the activation code to do it manually

Norton Network Security Map says the device is trusted, but it is offline.

Also is there a way to manual transfer files without the wifi. i.e. usb transfer cable

Are you sure that the 40s reset worked? Sometimes it takes a few trials for users to get it done properly. Remember also that the power needs to be unplugged, then you start pressing the button and you keep it pressed while you connect the power back, then you keep it pressed for at least 40s. You sould see the NAS power down and restart then.

Have been away for a week.

will try again, i didnt start it with the power off

UPDATE** Tried in various sequences but still not able to appear on network