My Cloud Login Problem


#1

Hi,I have had a My Cloud 6TB (gen 2)for over 18 months now,working fine,until this morning it wont open from my desktop,it goes to a login screen,and asks for Name and Password.Only the Name part is Solid blue,and won’t let me enter a name…I press sign in button,and it holds for ever,and does nowt.Bit frustrated now,as have done a 40 second reset, and it is all the same,unable to get in to box.Can someone help as to what may be happening.I am on Windows 10 on PC…Dont want to format box as it has all my files on…Thanks Regards…Kev


#2

How are you attempting to open the My Cloud? Using Windows File Explorer? MyCloud.com web portal?

Can you post a screenshot of what you see when you cannot access the My Cloud?

Can you access the My Cloud via it’s IP address?

Is the My Cloud showing up under Network in Windows File Explorer?

Do you have another computer or mobile device you can use to access the My Cloud as a troubleshooting step?


#3

I can see it in my computer,as wd my cloud, my smart TV picks it up, I can access it on mobile device, and view all content, ie, music, movie etc.I usually click on my cloud icon on pc desktop, and it opens to admin and user name, and what folders I want to open. Since yesterday, it now goes to a new screen, searching for wd devices. I try to open wd my cloud, it then shows the usual screen for a split second, then shows a screen which asks for name and password,but name is blued out when you try to enter name. Use password, then sign in, then after a minute or so, states, time out error… Will try screen shot tomorrow on pc. It opens perfect via mobile phone, or android tablet… Sorry its a bit drawn out.


#4

This is where it sticks.Looking back,it seems it is since last firmware update to my cloud.


#5

It appears you are using the My Cloud Desktop program. Are you attempting to access a remote My Cloud? One that is not on your local network?

The My Cloud Desktop program is not needed for local network access. Instead one uses Windows File Manager or Mac Finder to access a local network My Cloud.

For remote network access try using MyCloud.com. The WD Desktop program is end of life and recently it appears some have had trouble with it accessing their My Cloud devices after the latest firmware updates. One may have to, within the WD Desktop program, remove the My Cloud entry then re-add it using the proper login for either remote access (Cloud Access) or local access.


#6

Thanks for that, I will remove the desktop, and start again. I have tried logging in via wdmycloud, but cannot find device… I am struggling a bit, once again, thanks for hp.


#7

I think that it is now sorted, uninstalled all old wd stuff of pc, did a 40 second restore, then reinstalled to my pc, sorted out windows credentials, made a couple of folders on my desktop, can now see all in my cloud, and add to it easily… Many thanks for your help… Regards…


#8

Hi Bennor, Haystax,

I’m having the exact same problem with the blank name login, only I can’t uninstall the app to reinstall it! It gives me an error code when I try to uninstall:

Bennor, You say I should be able to access my storage device without this app if I’m at home on the same wifi network? How do I do that? When I click to open WDcloud in file explorer it takes me to web login and all I can do is view settings and stats but not my files. Am I missing something?

TBH finding this device pretty unuserfriendly when using with my PC. It works fine with my mobile and bubbleupnp for casting my music. Not so great for storing and retrieving docs if I can’t login via my PC! Ahhh!

Any suggestions gratefully received!


#9

The My Cloud Desktop program has been end of life since 2016 and no longer works on the second gen v2.x firmware My Cloud.

Users of Windows 10 should ensure SMB 1.0 is enabled. Recent updates by Microsoft to Windows 10 may disable SMB 1.0 which causes problems with finding the My Cloud in the local network neighborhood.

For local network access to the My Cloud one does not need of use any WD software or programs. The My Cloud should be listed under the Computer section in Windows File Explorer Network Neighborhood. Sometimes one has to select refresh in Windows File Explorer to get the My Cloud to appear under Computer. And one has to make sure network browsing is also enabled.

To make things easier one can “map” Shares to their computer.

It helps, if you haven’t done so already, to read through the My Cloud User Manual which explains in general terms how to access the My Cloud and use it’s various features/options.

WD My Cloud v2.x User Manual: http://products.wdc.com/library/?id=439&type=25&cn=4779-705147


#10

So it looks like File explorer in Windows10 is no longer supported by WD! That means I will have to try and resolve this issue with the desktop app!


#11

Thanks for your quick reply Bennor. I will have a read through those links and see if I can figure out how to access. They surely can’t say they arent supporting Windows10 file explorer mapping and not offer an alternative.


#12

Oh my goodness, thank you so much!
The instructions on the 2nd link worked and it is infinitely better having the drive mapped!

Finally, I can use this properly - Wohoo!

:smile::rofl:


#13

No. It is Microsoft who made changes to Windows 10, by disabling SMB 1.0 for security reasons, that made it difficult to access NAS devices like the My Cloud. This change by Microsoft affected a number of NAS (and other) devices including those manufactured by WD.


#14

Yes, I hate the way Microsoft is going! I’m a professional editor and I cannot get the new MS Office to stop crashing in Windows 10. I could understand it if I was using old software on a new OS, but both of these products are their new ones! It’s a kick in the teeth that you have to pay £6 a month for the privilege of using their unstable Office suite, so I’ve given up on it. I’ve had to ask my publishers if its okay to use googledocs instead, and thankfully all the forward-thinking ones have agreed!

I particularly dislike the way the Windows10 control panel etc is hidden away so it’s harder to change the settings.

FYI, the menu’s on windows10 for your fix are:

Windows logo>cog (settings) icon >search “Windows features”>turn windows features on/off>

Check box “SMB 1.0/CIFS File Sharing Support”>restart

Open file explorer (folder icon structure)> Network> select WD cloud from “computer” subsection to open your cloud folders (NOT “storage” subsection - that will take you to your settings dashboard).

Thanks again for your help :star_struck::+1::+1: