My Cloud is not connect to my home network anymore

My Cloud is not connect to my home network anymore. the led is light yellow and steady. I can not ping the IP now.
I have this device for one year. it works fine until end of 2015.

What troubleshooting have you done so far. Have you shut it down and tried a reboot? If you can still get to the Dashboard that can be done there. Let it sit for a while and have a cool down period before rebooting.

Are all your network cables inserted correctly?


i rebooted a couple of times already. i can not get to Dashboard because not network connection. I use cable network. My home network works fine (wire and wireless).

why my LED is yellow? hardware issue or network issue?

I gave you the two problems that are shown in an older My Cloud User Manual.

First is letting it cool down before a reboot to see if it overheated.

The second is to check the cables.

Do you have WD Quick View, if you do what does it show under Temperature?

  1. the device was out of power for overnight. i rebooted it again.
  2. my router shows green(connection is good) and the port of my device shows green . i also changed a cable.
  3. WD Quick View does not works due to no connect to the device.
    the only thing i have not done is manufacture reset. does it help?

I have the same…