My Cloud home is not found in devices, network, anywhere!

I’ve had MyCloud home for a while now, and it’s always worked fine. Recently my computer can not find it at all. Nothing has updated, nothing is different. It just doesn’t show up. I’ve tried every solution i can find online and NOTHING works because most of them require being able to SEE the device somehow. My computer acts like the device doesn’t exist.

It used to be the Z: drive, which still shows up, but when I click it, nothing happens… (it also used to say “heather’s my cloud home” not “Z”).

Even when I type the direct device into the file explorer bar, it doesn’t find any of my files! It finds the “public” files (of which i have none) but it doesn’t ask for any login info or show me my actual files.

I have tried adding credentials and it “worked” (meaning it accepted the credentials and they show up now) BUT it still doesn’t actually let me see the device in file explorer or on my pc or anything.

Please help, ALL of my work files are on this drive and I NEED to be able to access it through the file explorer. Accessing the cloud online and downloading the files every time I need them is getting infuriating.


I am having the same problem on two Windows 7 Computers as of today.

There is no longer an Icon to select the drive via the Desktop on either PC.

Also ‘WD DISCOVERY’ no longer recognises a MyCloud Home device exists, so cannot try re-logging in etc. It now shows the WD Hard Drive used inside the PC.

Previously Discovery, when clicked, showed the ‘Home’ device. I have made no changes to the computers etc.

As you may be aware WD updates the Drives firmware automatically, without any consultation or choice.

Since these access problems appeared overnight, and on two different Computers, each previously accessing one of the two drives I have, I fear the firmware update has ‘broken’ the ability to access the drives contents via the Desktop.

I can find nothing on WD sites, however they are now only stating Windows 10 / 11 compatibility re “WD Discovery”. No mention of Windows 7 or 8.

I realised there had been an Avast update last night, auto installed.
In case that caused the issue I restored one of the Computers to a backup I did in April.

Watching the screen carefully, the Icon that used to open the ‘Home drive’ contents appeared for a couple of seconds, and then disappeared. Afraid this tends to confirm WD have either deliberately removed this function, or it has been accidentally broken via a firmware update.

OK, got it working now on both PC’s.

Have to install this version of WD Discovery

Unzip and install.

On both computers during the installation a window appeared stating
'A JavaScript error occurred '- (click OK)

Run WD Discovery, the same Java error message appears, but after a few seconds WD Discovery appears, now showing the Cloud Home drive.

Click to Sign-in to the MyCloud Home device

At the next window ‘window - Open URL wdd?’
Select ‘Always allow, then Open URL button’

On my computers it would not let me continue, until
I re-booted Windows.

Now run WD Discovery again, and it will allow you to complete the Sign-in process.

You should NOW be able to access the Drive (Z) from the Desktop Icon which should have appeared, and WD Discovery should auto-run after booting to Windows.