My Cloud Home Device Offline - Bottom Ethernet Light Not On

Hi.

My Cloud Home device appears offline. The bottom ethernet (“Link LED”) is not on whereas for upper ethernet (“Activity LED”), green light is blinking.

My wifi Tx Rate is about 70 Mbps. Did slow internet connection cause it to appear offline?

@RoseRose Are you able to connect to mycloud.com and use it ? If you can’t what troubleshooting steps have you taken? Have you looked at the User Manual?

The below info comes from the UM.

@cat0w Last week, the bottom ethernet showed amber light. I was able to access to my files on mycloud.com but not on WD Discovery.

I have looked into the manual. I restarted the router and the device but to no avail.

Now I am unable to access the device both on WD Discovery and mycloud.com. Still no light on the bottom ethernet.

Do you have another cable that you can try?

@cat0w Nope

try another cable (cat5e if possible); make a direct connection (router - MCH)
try another router ethernet port
try in last time try another router.
if your device always appear offline, call SAV.
Hoping you will be able to fix that problem

I have exactly the same problem. Worked fine for a year and now offline and unable to get the Link light to register. I have tried everything - reset the MyCloud, reset the router, tried a different LAN port. I am just about ready to give up on this useless piece of garbage and go back to good old reliable external hard drives because this thing so flaky. Is a hard reset about all I have left?