My Cloud Home and SanDisk ibi - Important Update About Access To Your Files








Although I am not affected directly, I would like to translate your message into Italian and post it in the Italian forum. Can you authorize me to do so?


Confirm… works for me too. At last…

Thank you very much, WD-support team! I was able enable local access to my files now!

I really happy :clap: :clap:

It’s only took me 5 minutes following your instruction

Mine isn’t working like I thought. The MyCloud is on my network and I can access it. But there is only 1 file folder that opens. It’s one that has the back up to the pictures on my phone. None of my other files that I access thru WD Discovery are there. Are they hidden somewhere? Are they in the cloud and not on my NAS? Help!

Hi there. That didn’t work. It shows me “{“key”:“internalServerError”,“message”:“Internal Server Error”}”.
I think that is because my home duo is stuck on firmware 7.16.0-220.
Please provide a way to manually update the firmware to the latest version, as it is clearly stuck.

Thanks for providing local access. I’m running a new backup now.

I bought my MyCloud Home Duo mainly for sharing large files, and for accessing files remotely on different devices, and contractors and collaborators whom I work with are set up to exchange files on the drive. I’m glad that after 5 days, at least I have access to my data on my main computer, but I hope we’ll have this problem sorted out quickly, so we can get back to work without having to use other workarounds to exchange files conveniently.

I got as far as this after watching the video. I’ve tried my mycloud log in and windows log in. Any help appreciated.

You must choose different username and password earlier

Didn’t work for me, unfortunately. Was able to set up local access with user name and password, and the device appeared in the file explorer but when I click on it, I get this…


I had not had Local Access previously set up before this, and going by the tutorial, once I had set it up, I should have had to verify with 2FA. I have not had an email or been able to accomplish this, and yes, I have tried different email folders :man_shrugging:

[note] - I have myself and another user registered to use the device and I followed the procedure for us both.

I now have access to all files in the LOCAL area on the MAC. Took a while to figure out but now it works. Thanks

Miscellaneous directory names are corrupted and now have letter-number type names

Time to look at Synology NAS products


It has to do with special characters not being supported in this view type.

I am trying to get Local Network Access on my Windows 11 Desktop. The MyCloud Home Duo device is connected on a WIFI hub through a local switch.

I have created a Local Network Username & Password (as per instructions on Instructions to Enable Local Network Access on a My Cloud Home, My Cloud Home Duo and SanDisk ibi) using the Dashboard.

However when I go to Windows Explorer and click Network, I cannot see the device.

Do I need to connect my Desktop to the MyCloud Home device directly with an Ethernet cable in order to see it ?

I’m back on local access . I am however moving on to google drive for my cloud.
enough of being so dependent on small companies who can’t take care of their own security, let alone mine. for all we know our data has been stolen by some 3rd world brigade in Stonia.

In W11 explorer you will find your drive under “Network” , not under regular drives.
You can either start using your files from there under “Network” or if you want it to appear as a network drive, then you need to 'Map" your drive first. Once you have successfully mapped it, it will appear as a regular drive in your explorer, but you don’t have to map it, to use it.

You need to use your WD id and password to gain access to it. Once there you can set the option yo “Local Access” to ON and there you will be asked to setup a “local access ID and password”.

Google drive is certainly an option.

Of course, google has a reputation for abandoning products.
Also; you will now have a monthly fee. If you care for your data - - → Don’t ever, EVER miss a payment.
So. . . .FUNDAMENTALLY there is no substitute for backing up data in multiple places.

The problem here is that by design the MCH requires internet access for functionality. This is a fatal flaw for a local home use device. There are other choices for NAS units that do not require constant Web Authentication (more like: Hard to find any reputable NAS that requires Web Authentication like this)

1 Like