My Cloud gen2 easily install Transmission

It is really so easy, just 3 steps

  1. Download the attachment

  2. Unzip in mc Public folder

  3. Ssh connect to your mc, Run this in console
    sh /mnt/HD/HD_a2/Public/

Ok, you get it, If reboot or shutdown your mc, just do step 3 again

Then use transmission with http://your mc ip:9091

The default gui user/pass is: username/password .You can change it with edit the file “”

The download folder is Public/transmission

Works well (216.9 KB)

1 Like

Any1 tried :> ?

Works well.

works perfect :wink: thanks.

btw: can’t change username and password. Dir changed, but Im unable to change user and pass ;/ edited the sh file, but still have to use default.

He-he… How about this?

Hi would it be possible to enable this apps tab on


The App modules would have to be recompiled for the older gen 1 v4.x firmware because the older gen My Cloud uses a different page file size (64K if I remember right). Further there is no “define.js” in the v4.x firmware (that I can find by searching). And the HTML code of the rendered Dashboard under v4.x also does not have an “Apps” entry in the nav bar area of the code.

The better way for the older first gen My Cloud’s is do something like the following:

Or if one wants Transmission alone:

Or see the following:

There are a number of prior threads for running Transmission under v3.x/v4.x firmware first gen My Clouds. One can use the forum search feature, magnifying glass icon upper right, to find those other threads.

Hi! You did a great job!! It works flawlessly.

I did your procedure to enable apps install tab: WD MyCloud Gen2 - Enable apps install tab + Apps!

It works like a charm, but now I have a doubt. In the procedure of this thread is very easy to change user and password, but installing “WDMyCloud_Transmission_2.92.bin” now I don’t know wich user is set by default and I don’t know how to change it.

I would like to change it or set it because I want use auto torrent adder Chrome plug-in adding some security sending the torrents to the MC.
Please, could you tell me how to change it? Thanks!!

/mnt/HD/HD_A2/Nas_Apps/Transmission/settings/config.json (Or something like that).
User/pass by default: transmission/transmission (Its defaults for transmission, builded from sources)

Thank you! with your help and a bit of investigation now I have my Torrent client working with password and I can add “on the fly” torrents from Chrome with Remote Torrent Adder for Chrome plug-in.

I’m going to explain here the procedure for those who wants to do the same or may help them for similar configurations.

First, the Torrent client that i’ve installed haven’t user or password by default. Once you have installed Transmission and you can access to it’s admin web (http://yourwdmycloudIP:9091) the port could be 9092 or any other, you can see where it is configured later.

You’ll need connect by SSH using app like PuTTy:

There is a configuration file (config.json) wich contains user, password, port, and many other configuration parameters of transmission, we need modify this file with the desired parameters.

First of all we should disable Transmission APP in WD MyCloud console (only disable, not uninstall) or disable the service only if you know how to do it. We need it because if the service is running, your changes will be overwritten with the original parameters.

Once you have disabled Transmission, start SSH connection and go to the following path (you can copy-paste, paste with mouse right button in PuTTy) :

cd /mnt/HD/HD_a2/Nas_Prog/Transmission/config/

If you want to see what is in this directory or any other type: ls -als

Now we are going to edit the file config.json, type:

vi settings.json

The file will be appear on the SSH connection, to change to “insert mode” push “i” from your keyboard and escape “Esc” to exit insert mode.

With the keyboard cursor find the line with “rpc-authentication-required”: false, and change to true
Then delete the string in “rpc-password”: "{a5d5b0ef… ", and write your desired password, for example:

“rpc-password”: “mypass001”,

Don’t worry about the encrypted chain, when you re-enable Transmission, will read the configuration file, and when it find the unencrypted pass, will encrypt it automatically. The next time you access to the configuration file after enabling Transmission, you can see your password encripted.

The last one is the user, go to the line with “rpc-username”: “”, and write your desired username, for example:

“rpc-username”: “myCloudUser”,

You could modify any parameter you want (and you know what’s mean) in the file. When you have finished press “Esc” key and then type:


Then enter. This writes the file and quit from the editor.

Now you can start Transmission from WD MyCloud pannel and test if it works. It shoul show you a windows asking you for your username and password.

Cheers for this, worked perfectly. The issue i’m having is the download directory keeps changing itself to Transmission after I stop and start the service. Any ideas? it’s happened on 2.84 and 2.92. It also unchecks use port forwarding on both versions.

Same as @Cal_G
Im on 2.92 Transmission (from fox.exe), on firmware 2.21.119.
Transmission is not run on webgui and ps | grep trans shows no transmission running.
tried to edit settings.json in /mnt/HD/HD_a2/Nas_Prog/Transmission/config/ change some settings and it worked (user, pass, temp folder, etc) but the destination download folder is not, it revert back to “/mnt/HD/HD_a2/Transmission”.
Any ideas?

I just change the directory to where I want it if the device has been rebooted. I had to change a permission setting also as the files were owned by root and couldn’t be deleted from within windows. After that it worled well.

you mean stop app, reboot wd, change settings.json, start transmission << download directory is change from /mnt/HD/HD_a2/Transmission to any folder you set ?
I tried that but it still revert back to /mnt/HD/HD_a2/Transmission
temp folder is moved and its 755
download folder is not moved and its 755, tried 777 also not moved

1st - all changes to settings.json must be done when Transmission isn’t running.
2nd - there is a bug in “/mnt/HD/HD_a2/Nas_Prog/Transmission/” - download-dir will always be “/mnt/HD/HD_a2/Transmission”


transmission-daemon-addon -M --port 9092 --config-dir $path/config --download-dir $DOWNLOAD_FOLDER --pid-file $PID_FILE


transmission-daemon-addon -M --port 9092 --config-dir $path/config --pid-file $PID_FILE

“download-dir”: “/mnt/HD/HD_a2/Public/download”,
“umask”: 0,

this change will ensure that downloads go to “/mnt/HD/HD_a2/Public/download” and are available to all (777).


@rina11, Thanx for bug report. I will repack this app soon.

Fox_exe, I owe you a huge THANK YOU for all your work you’ve done for wdmycloud community!
I glad I helped.

1 Like

Hi! Great job dude!!! Client works cool!! Big respect from Russia!!!

Muchas gracias por la información. Funciona! It Works!

This works perfectly. Thank you very much :slight_smile:

By the way, did anyone know how to add torrent to transmission on WD mycloud remotely on different network?