My Cloud gen2 easily install Transmission


Can you please help me, how to change permission settings , because I also have the same problem? Inside settings.json?

I can’t edit/delete files from Win, because they are owned by root.


hi i am not able to install transmission on my 4tb my cloud 2 gen .

i am not able to understand

Is it normal that this app is use only one core of processor? Downloading speed iis going up to 10MB/s only (my internet is 200Mb/s) and is it posible to download sequential from first to the last part?

Where are you downloading from? Might that be where the limit lies? Did you mean 10Mb/s or 10MB/s (bits or bytes)?

It is a torrent on windows it download with speed 26MB/s on WD 10MB. I mean 10MB/s not 10Mb/s

It was perfectily working and showed connection failed message as below.

I did reboot on putty and the dashboard came back but still connection failed.

Can anyone help me? firmware ver 2.30.193

Tried with the new OS 5, couldn’t make it work.
Can someone help with a step by step guide for dummies?


The single bay My Cloud units are not supported by OS5. See the dedicates subforum for the OS5 supported My Cloud devices.

Many people are looking for a solution in OS5 apparently:

Thanks for the overview - guess I have to find another solution (and provider of my next NAS)

From os5 this method is dead.

Now we have got a new extended playstore thanks from @Fox_exe link is here:

Transmission 1.15 tested and working. Just download bin file and manually install from os5 managing web.

I invite you to test all this new apps and comment here how it works.

Thanks a lot @Fox_exe

1 Like


Thanks a lot for your update for OS5. I just upgraded recently and realized, that my transmission stopped working, so it was great to find an out of the box solution.

I would have a question for the OS5 versions:

  • currently there are two versions available on the linked page: v1.15 and v1.99-2.92-2. What is the difference between them? I started with the 1.99, which was installed successfully, but did not do anything when I started it. Then I tried v1.15 which seems to be working on my end

Thanks in advance

1.15 - Is a app version. Actual transmission version is 2.94
1.99 - Just for overwrite any previous app. Actual is 2.92 (and its 2nd repack/fix). And it is just a repacked version from OS3. Sadly, not work.

1 Like

Thanks a lot for the explanation.

After using the client a bit I have another question. It seems stopping and restarting the service resets the settings (seeding, upload/download speed, port, etc) to defaults. Is it possible to edit the config file to have my own default settings? (similarly how it worked with the original (OS2?) version)

hello, before i used os 3 with transmission, and i could access transmission from outside, then i can’t connect outside of my local network, does anyone have a lead?

Hello, have you repackaged Transmission yet? I followed @rina11 steps and now I am getting 503 Service Unavailable.

hello, no have links for download anymore , if you have share please

Hello Everyone,

Since the last firmware update (5.27.157) the v1.15 client doesn’t work on my NAS. On the APPS page it is displayed like it was running, I can stop and restart it, I don’t see anything in the system logs (I have already enabled extended logging). However when I try to access the Transmission page, it runs to an 503, so it seems the service is not running.

Did any of you face the same issue with the latest firmware? Are you aware of any newer Transmission version than the 1.15?

Thanks in advance

The following list has all the latest NAS apps, including Transmission version 1.16 for the latest OS5 firmware update.

My Cloud OS5 Apps Matrix