My Cloud Destop won't install

Hello All, My first ever post. I have reset my cloud device and downloaded as showed on video. My laptop downstairs no problem. All four icons appear on desktop, WD My Cloud, WD My Cloud Dashboard, WD My Cloud Public Share & WD Cloud Learning Center. That’s all fine. But when I do exactly the same on my other laptop only 3 icons appear on desktop, the last three from above but will not show WD My Cloud. I have had it all installed before on both laptops but I removed everything on both laptops when I reset the device. Any help will be most appreciated. Many thanks.

While on the local network there is no need to use the WD software to access the My Cloud. Once one has properly setup and configure the My Cloud, using a web browser for example (see:, any computer on the local network should be able to access the My Cloud using Windows File Explorer or Macintosh Finder.

If you have not already done so it is recommended one read the My Cloud User Manual (, which explains how to access the My Cloud using Windows File Explorer or Mac Finder and how to map a Share to the local computer for easier access.

More information on how to map a Share:

If you just want it on each one and they are all on your network you should be able to drag and drop or copy and paste. The icon may not look the same. See example image below taken from my laptop after a drag and drop. Icon is white with a small black cloud.

I reread your post, are you wanting the My Cloud Desktop app or the Link to the Dashboard? If it is the app you want go to the Learning Center.


I will read this and try it. Thanks for advice Bennor. Much appreciated.

Hi cat0w, Don’t think I have ever seen the drag and drop icon you have shown above. I have the Dashboard icon. Its was WD My Cloud, on yr picture 5th counting down. I I have been to the learning centre and tried to download from there, it shows it downloading but does not. I have checked my two laptops and have checked in my program files x86 and on my ok laptop the WESTERN DIGITAL file is there and on my problem laptop it isnt. I have tried doing the whole set up again but wont have it. I feel ike I am going Bennor has said there is another way to get to files in device without using WD My Cloud on desktop. But I a creature of habbbit I guess. Thanks for yr help. Cheers.

Hi Bennor again, Yes I have done this already, I was thinking as the icon was there before it should be now. But at least I can see all my files now. Cheers.

Are you in the habit of using File Explorer? Because that’s the alternative (and largely superior) way of accessing a MyCloud local to your network. It’s what Bennor is suggesting.

@CLIFFORD_HUDSON Try this link and make sure to save the download to your downloads folder. If this works and installs you may have to do an update to the newer version.