No acces to MyCloud

Hello, I haven’t used my MyCloud for a long time.Now I try to install it again, but get an error message.
It’s in Swedish and look like the attached picture.

What’s wrong?


Was it set up to use Swedish, or has it spontaneously decided to start speaking Swedish…? I don’t speak Swedish, so I’m not sure what it’s saying; there’s a problem, you can continue with the installation, but you may not be able to…

If you had already installed it, then it has already been set up, and you won’t need to do that again. You may need to connect to it again, though.

What are you doing to ‘install’ it? What tool are you using?
Are you accessing the Dashboard?
What are you trying to connect to it with (PC. Mac, tablet, etc)?
How long is it since you last used it?

Because you haven’t used the My Cloud in a long time and you are trying to “install it” I would suggest you perform a 40 second reset first then connect the My Cloud to your local network router, then try to access the My Cloud Dashboard using a web browser from a computer wired to the same router as the My Cloud. It would also be a good idea to update the My Cloud to the latest firmware version as well which can be done through the My Cloud Dashboard.

If you haven’t done so already you may want to review the My Cloud User Manual ( in case you forgot how to configure the various features/options of the My Cloud. Note: There are now two different User Manuals for the My Cloud due to WD releasing a newer hardware version of the single bay My Cloud last year. If your My Cloud is more than a year old its a good bet its the first generation v3.x/v4.x My Cloud so make sure to select the correct User Manual. Or see the My Cloud Dashboard Help.

I have done what you suggested. But I still have a problem. I can’t reach MyCloud from my PC.
I can reach it from my iPad.
When i try to reach it from the PC i get “Failed to connect to the device” see picture.

I can connect to the dashboard, see picture.


Can you access the My Cloud using Windows File Explorer?

Generally one doesn’t need to use the My Cloud Desktop application for local network access of the My Cloud unit, instead Windows File Manager and mapping the My Cloud to the local PC are the preferred methods of access.

In addition to Bennor’s good points, have you tried any of the options in the bottom right corner?

Search for devices
Show previously connected devices

Hi Bennor, I’m not able to map any network drive!
At point 3, when I Browse, I don’t get any folders. Just the box (Swedish)

I have also tried the 4 options in the bottom right corner as cpt_paranoia suggested. Did not work!


Have you upgraded Windows since you last used the MyCloud?

Have you set up the Windows Networking correctly? In Win7, it’s under Control Panel/Network and Sharing Centre/Advanced sharing settings.

You need the following settings

  • private network
  • network discovery on
  • file and printer sharing on
  • set identical Workgroup names on both PC and MyCloud

I think…

Hi, I haven’t upgraded. I have W10. Where can I findthe settings in W10?


WD Support - I am having the same problem, as are apparently hundreds of Mac users at the moment. I don’t understand what “access the Dashboard” means or what a ‘single bay’ device is. Clearly your products are not geared toward the general public, even though you would think they should be… I not a frikking techie and there’s not a single customer service person I can address my problem to. I guess I’m taking this back to Target.

This is a user forum, not WD Support. Bennor doesn’t work for WD.

WD Support can be found by simply typing ‘WD Support’ into Google, or by hitting the ‘Contact WD’ link at the bottom of this page.

If you had read the user manual, you would know what the Dashboard is, and how to access it.

You can find the user manual by simply typing ‘WD My Cloud User Manual’ into Google. Or by following the links in Bennor’s post.

If you had done some basic product research before buying your MyCloud, you would have found that there are a number of models in the product family. Some of these have more than one disk drive ‘bay’. The basic MyCloud has a single HDD.

Most of us here (including myself) are users here not WD employees. We came here to solve one problem or another and have stayed (at our own time/expense) to help others such as yourself. There are multiple models of the My Cloud device, some with multiple hard drives (or bays), and the subject of this subforum is the two My Cloud models with a single hard drive (or single bay). There are differences between the various models, which is why we try to be specific when giving suggested workarounds or directions.

The My Cloud Dashboard is the interface one uses to configure the various features of the My Cloud device. One can generally access the My Cloud Dashboard using one of the following addresses in their web browser:
Windows PC: http://wdmycloud
Mac: http://wdmycloud.local

Or see the following WD Support document:

If you have not done so already (and haven’t returned the My Cloud unit) you should read the My Cloud User Manual (see this link: which explains how to use the My Cloud device and its various features.

If you need to contact an actual WD Support person see the following:

Further more help can be found at WD’s Support site:

The My Cloud is not some simple device like an external hard drive that you simply plug into your computer. It is a network attached storage device (NAS) and requires some configuration and setup on your local network to operate properly and effectively. If you are having trouble reaching the My Cloud Dashboard page sometimes the cause is your local network configuration or an issue/setting with your local computer. It would help if you provided more information other than the generic “I am having the same problem, as are apparently hundreds of Mac users at the moment.”

What My Cloud model do you have?
What firmware is it running?
What Mac OS are you running?
What troubleshooting steps have you tried?
Is the My Cloud connected to a router?
How is the Mac computer connected to the same local network as the My Cloud?
Have you tried to reach the My Cloud using the My Cloud’s IP address obtained from your local network router?

It is hard for your fellow My Cloud users to provide effective help unless we are provided more information about your specific issue or problem and your computer/network setup.