My Cloud app no longer streaming to Chromecast

I have been using the MyCloud App to stream to Chromecast, but it no longer is working. I select the Chromecast and it show the name of the movie on the tv screen and then Western Digital shows on the screen an the movie does not load. I have tried on two different devices and two different tvs and both have the same outcome.
I have reinstalled the app on my phone, I have rebooted the chromecast and I have also rebooted the My cloud.

What can I do to rectify this issue?

Thanks

I am having the same issue. I have been using the wd my cloud app to cast to my TV for weeks with no issues and all of a sudden this is happening.
I find if i reboot my mycloud it sometimes works again but typically if I stop casting for a while (like when I go to work) when I come back it doesn’t work again.

I have tried resetting my Chromecast back to factory default, reinstalling my apps and have tried multiple Androids.

Same here. Chromecasting from the WD app for Android appears to be broken. When I launch it on multiple devices it fails to properly play/cast to the Chromecast from the WD mobile app for Android. Casting Youtube video from the Youtube app to Chromecast works fine.

When I attempt to cast music from the WD app, the app suddenly tries to cycle through a bunch of songs even though I selected a single song, before it stops on a different song than the one I selected and doesn’t cast to Chromecast.

In all cases the Chromecast on the TV simply displays the “Western Digital” logo without any media being cast.

Edit to add: At times the WD app simply locks up and doesn’t respond forcing me to force close the WD app.

1 Like

So I have now re-installed the Google Home app as well as the My Cloud app on my android phone and still not working. Please does anyone have a solution? Feeling like the My Cloud was a big waste of time now.

It may not be a solution, once I can’t troubleshoot your problems, but may be a workaround so far: install BubbleUPnP in a mobile device and try to cast from MyCloud through Bubble choosing Chromecast as renderer.
Let me know if it was of any help.

Hi, Thanks for the suggestion. Can you please help me how to set it up :sweat_smile:. I have MyCloud Home and I purchased the BubbleUPnP app. tia:pray:

Hi Bennor, all, I am experiencing the same “Western Digital logo” issue when trying to cast photo’s/video’s from MyCloud mirror to Chromecast via Android’s “My Cloud app”. Any idea how I can fix this? I am only trying to cast simple JPG’s and MP4’s. Tx.

Try using a different app to cast content from the My Cloud to the Chromecast if the WD App is still broken.

Thx. Any suggestion?

Download the ‘all cast’ app. Works fine for me although I think I paid for the premium version

Open the all cast app, select the relevant player (in this case chromecast). Then from the menu, select the media server option. It will then find your WD cloud device, select the video file and voila!, the file will play through the chromecast. It will only play certain types of files though, for example .mkv are not supported

For smart TVs, you can also select the TV as the player so a chromecast isn’t even needed…

This is based on an android device and check your smart tv specs before deciding against the chromecast

Another way round this (again for android) would be to download the video file to your phone and use your all cast app to steam to one of the players. Just instead of selecting the media server option in the all cast app, choose the file browser and pick up the video from the devices file location

Hope that helps

Edit - a list of supported file types can be seen here -

Tx Gladders! I see the Mirror as one of my media servers in the All Cast app. The only thing is it only checks the “Photo’s” folder, which I don’t use…
I would like to change the main folder, via my read-only Mirror account. Is this possible on the Premium version?

Tx. again.

Rob

Hi Rob

I’m not sure the app will do this. Have you checked that the share on your cloud device is set to public access or media sharing is turned on?

You can do this by loading the cloud dashboard and checking the shares setting.

I have two folders, public and private. The all cast app seems to consolidate all mp4 files into it’s own video folder and photos in a photo folder (the video and photo folder does not exist as folders on my cloud device)

Seems like this would be permission related to me

Cheers

Tim

Also, what device are you using?

I’ve had the same problem for the better part of a year with no help from wd. They dont even read the tickets they always reply with a link to what media types can be streamed even though I keep telling them nothing will stream to chromecast and the stuff I cant stream now used to stream when I got it and nothing was changed on my network and the drive has been reset 3 times and is setup 100% Correct. I even gave them a list of other apps on the playstore that will see the drive and stream to chromecast without any issues at all but they will still send that ■■■■ link again

Sorry, mate, only today I realised new replies, more importantly yours. Have you sorted out yet or do you want a walkthrough?