My Cloud 2 TB - Various problems

Yesterday, I installed a new WD My Cloud 2 TB. After one day of usage, I encountered some severe problems:

  1. On my MAC with OS X El Capitan version 10.11.6, it is impossible to connect to WD My Cloud from Finder (“Connection failed”);
  2. The WD My Cloud app on my MAC desktop sometimes refuse to connect to the WD My Cloud. The problem is solved after a restart of the MAC desktop.
  3. The WD My Cloud app sometimes stops uploading files. The problem is solved when you restart the desktop.

Any suggestions how to solve these problems?

Do you have other systems within your network you can test in order to isolate a system issue vs. a device issue?

I have e.g. the Apple Time Capsule. No problem to access this storage system from Finder. WD My Cloud works well with Infuse app (on iPad and iPhone) and MusicStreamer app (on iPad).

Today, I still have the same problems (no access from Finder - WD My Cloud app sometimes stops without message).

I defined a new share with smb (smb://ip-address/public) and nfs (nfs://ip-address/public). This works from finder. However, this is very, very slow… The WDMyCloud automatically defined during installation, will not connect (‘connection failed’). It seems that this share has no access to the WD My Cloud.