My Book suddenly not visible


#1

I’ve been using the My Book (not sure of the model, it’s black with a round blue light, I think it’s home basic 250GB, but not positive) with Time Machine for a year or more. 

I recently applied the OS X update (not sure if that matters) and now I can’t see external drive. I can’t say for sure that there is a direct correlation between the update and the drive being not visible.

I rebooted the Mac (Snow Leopard 10.6) and powered down the MB to no avail.

Any ideas?

Thanks!


#2

Plugging the My Book directly into the wall socket resolved the issue

I received this from tech support

Thank you for contacting Western Digital Customer Service and Support. My name is Gustavo R.

I apologize for the inconvenience that you are experiencing, I have a few questions for you. Are you hooking up your external hard drive to a USB hub or extension cable? It is always recommend that you plug your external hard drive directly into your computer. Are you using the power adapter we supplied with your drive? 

Do you plug your external hard drive’s A/C adapter into a power strip or directly into a wall socket? If you are using a power strip or battery backup then we recommend that you connect your hard drive directly into a wall socket. In the past, we have seen several customers who have had issues using power strips and battery backup devices

Have you installed the latest OS updates as well as updated the USB controller drivers on your computer? Have you tried connecting your external hard drive’s USB cable into a different USB port on your computer? When connected to a different port, do you have the same problem? Have you tried a different USB cable? Are you experiencing any other problems with USB devices on your computer? Does your external hard drive have the same problems if you try it on a different computer?


#3

I have the same problem.  I have a My book for Mac.  I have used it twice with no problems but tonight I cannot get any image from it on either of my computer screens.  I have tried all of your suggestions.  None have worked.  I bought it only nine months ago.


#4

Me Too!

 What to do? 


#5

Thought I’d share my problem/solution.

My Drive stopped beng visible, no lights, no sound, nothing.

Tried: unplugging everything, restarting computer, replugging. Different USB slots, different USB cable, different computer. Still nothing.

Plugged in another hard drive to same power lead, got a slight flash from lights when I plugged into my computer so guessed it was a power supply issue.  Hunted around and found another power cable. Ta-dah!

Looks like the suplied cables are pretty budget (sorry WD, but true…).  If you’re getting nothing from your drive, I suggest you try that as a fix.

good luck!