My Book Not Appearing in Finder Nor in Explorer

I’m on a Mac Pro (early 2009) and use a WD My Book as a fifth hard drive. It was fine one day, gone the next. And the light went out. The drive doesn’t show in Disk Utilities nor in Finder. However, I can still feel the drive running and the small window on the side still shows capacities. I don’t think the drive is really bad. I might add that I also have Windows XP in Bootcamp, and the drive can’t be seen there either in Disk Manager.

I’ve tried different cables and different ports, ones that I know do work. Connection is Firewire 800.

Any thoughts, ideas, or help would be much appreciated. Thank you,


If the unit has a USB connection, try to connect it to the computer via USB to see if this way it comes up.

Thanks. The connection appears to be a mini USB, but I can’t get either of the cables I have to fit that connector. Do you know if it’s mini or micro? I wish that WD had put in a standard USB socket, but alas, they did not, at least not in the My Book I have.

Following up here. I did find a cable that fits, surprise, surprise. I think it’s mini. Anyway, no go; it doesn’t work using USB either. I can still feel the drive running but still no light and no appearance in Disk Utilities.

You said that the light would not come up on the unit? try to connect the power directly to a wall outlet see if this helps.