WTF? My Book doesn't appear in Finder anymore


#1

I didn’t update anything unless it did so without my permission and warning.

I didn’t download, transfer or install anything particularly and no one but me could’ve touched it.

But when I plugged My Book (WD500H) lastly, the driver icon did appear, the static light and the moving reading light we’re on the MyBook, but nothing appeared on my Finder anymore, I can’t access or find MyBook and I have my [deleted] thesis saved on it !

I don’t know what it is or why it happened, and it seems like it’s functioning (MyBook is light up and looks like it reads datas when I plug it) but it doesn’t appear on my Mac anymore and I can’t access it.

What is going on, and how can I fix that ??


#2

I feel your pain, brother. The same has just happened to my new 1TB 2.5" passport.

(I reformatted it when I bought it to OS extended (journaled) the day I bought it)

Now, about a month later, it’s suddenly not seen by the OS X 10.6.3 Finder.

Not seen by disk utility.

Not seen by system profiler (About this Mac).

Not seen in Terminal by running df.

Here’s what happens (now) when I plug the drive in to my 27" iMac core i7 (until now it’s just mounted to the desktop)

  • little white light on HD comes on immediately and stays on

  • 6 seconds later a distinct (and new) single click sound is heard clearly from within the drive case

  • 2.5 seconds later another click (the same sound, repeated)

  • 2.5 seconds later another click (same)

  • 2.5 seconds later another click (same)

  • 2.5 seconds later another click (same)

  • 2.5 seconds later another click (same)

  • at this 6th click, the white light begins flashing (approximately)  three time per second

  • the drive will not mount and the light will keep flashing indefinitely until I unplug the USB cable

ONCE in the last 20 connection attempts, the disk showed up in Disk Utility (and under df in Terminal).

  • the Verify Disk option gave an immediate message about needing to select the “repair disk” button.

  • Repair Disk option failed immediately, citing the reason for failure as inability to UNmount volume

  • tried to erase volume AND repartition disk, both failed, citing inability to unmount.

  • attempted to repair disk permissions, but cancelled when each file showed up in Disk Utility log window as something like “error - file not available - [path_to_filename]” (that’s not verbatim; just the gist)

  • I quit ALL apps (only Finder still running) and tried to unmount drive from desktop (cmd - e)

  • failed with error dialog citing - some program appears to be using drive (not verbatim).

  • selected the force eject button, and the disk ejected

  • now unable to reproduce this, as drive will not mount at all.

I want this (my only backup) drive working again.

So what do I do?


#3

Well it seems like it’s not about the MyBook not appearing because after 10 attempt it did, it’s about it taking 5 minutes to appear !

I didn’t not upload particular files recently and the MyBook and cable seems to work fine since it did appear finally. But I’m wondering if either the MyBook firmware or OSX 10.6.3 **bleep**ed the speed, because it’s like I had a USB 0.5 connection…


#4

@ myWDaintWorkin,

To be honest, it appears that your drive has failed.  You may want to seek data recovery, since it looks like it’s the drive mechanism.

@ Augure

If you can, you may want to back up your critical files from it.  And until you know whether your drive has failed, or the partition has been damaged, you may not want to trust it.