My Book Live Duo Yellow light on

Hi all

I’m wondering if anyone has encountered a problem with their My Book being un responsive and displaying a solid yellow light?

I checked my email the other day and was smashed with emails advising that the device had restarted? I still have no idea what caused that but the emails did give an “event code - 2001”.

No the unit is completely unresponsive. I have already tried the following to solve the issue:

Powered the unit off (both for a few minutes and even  a couple of days)

Resetting the unit

Changing the ethernet cable

Changing the port on the router

Plugging another device in to the ethernet cable to see if it would connect to the network (which it did)

Plugging the device directly into my computer and searching for it

Mapping my network drive

entering the IP of the device to see if I could connect that way

Checking the power supply with a multi meter to make sure I was still getting a full 12 Volts

After all the above I’m still no closer to connecting to the device or getting the indicator to turn green. Any thoughts or advice would be welcome.

Thanks in advance


Just a small update.

I have now also tried a different power supply of 12v 3amps but still no joy :frowning:

yip, happened to mine about two weeks ago. totally unresponsive and not recognised by the computer. Tried all the same stuff as you except the multimeter.

My disk A doesnt feel as if it’s spinning, so thought ot was a disk failure, tried the good disk, disk B in slot A on it’s own and still nothing. Mine is set up as Raid1.

Now coming to the conclusion that the enclosure is knackered. warranty time I think.

This has happened to me too. It had been configured for RAID 1 so unless both drives are trashed, I should be able to recover the data that is/was there. Anyone know how to do that?

pull disks out of  drive.  Attach disk A to a Linux PC via USB-SATA cable.   If you can’t run Linux, then install software on your computer than can read a disk formated in Linux ext3. 

Ok so I recieved a response from support which suggested a number of checks on my network settings on my computer and connecting the power source directly to an outlet (instead of via a surge protector) etc…  I tried all their suggestions but still no luck. I’m further convinced that the MLBD is the issue as their is no other likely explaination for the issue.

I will post a further update as the become available for others facing the same issue.

I tried several local shops to see if they could get mine hooked up to a linux pc, not luck. Eveentually had to send it away to one of WD’s recommended data recovery specialists, turns out drive a had a complete power failure. Not a problem i thought as I’ve configured it as Raid 1 from day one, no, the setting i selected were never implemented by the software or had been over written at some point during the life of the drive. Turns out i was faced with a hefty bill to recover my data as it was a stripe not a mirror as I’d tried to setup.
Not very happy that I’ve been left out of pocket for something that shouldn’t have happened.

Ok so looking for some more advice please guys.

I tried buying a new power source and a couple of other things and the unit is definitely dead. I’ve since purchased a new NAS and want to recover my old data. I purchased a universal sata device to connect the drive to my laptop. I can now connect to the drive but can’t access it.

So after some help from dr Google I tried using the free version of “disk internals” program to recover the data but while it can see all of the folders,
most of them show up as empty. I’m wondering if this is due to it being set up with 3 terabyte raid mirror instead of the full 2 drive 6 terabyte. Is that likely to be the problem? Some files are there but most aren’t.

Anyone got any good advice on how I can best recover my data.

There is a slight misconception here.
Plug unit in, you get the blue light, indicates power on and when drive is sleeping.
Unit switches to Yellow next and loads operating system and then initializes the drives (no DashBoard yet).
If there is a OS loading issue then it will hang on the yellow light.
If it loads the OS and all is good then it will turn green and you should reach the DashBoard by Ip address.
If there is a drive issue then the light is RED but you should get the DashBoard to connect by ip address.
RESET button does not work if there is a Yellow light on, No OS has loaded or finished loading.

Now if the Yellow light is on steady and never changes, then you have what the industry calls a Brick.
Also you will have to debrich the drives and the unit will come back alive, now you may or may not recover the data.

1 Like