My Book DUO completely unresponsive

My 4TB duo is completely un responsive and no longer shows up in explorer -  Have reset, re booted etc and still no luck - tried support and he ran the wd discovery app with no success either - downloaded linux recovery software and it to cannot see the device - no access what so ever. still powers up and goes from blue to green light in front

any advice greatly appreciated

Hello and welcome to the WD community.

If you ping the device, does it respond with an IP address? Also try to connect the unit directly to the wall outlet in case it is connected to a surge protector.

thanks, could you explain how to ping the unit?

what is the IP address of your MBLD?  Find it in your router DHCP/LAN table.

Then google ‘ping an IP address’ to learn how

I have exactly same problem.I called the WD tech help and only fix is replace it.

Unfortunately there appears to be a problem with RMA and keeping my data on the two duo drives?

Hopefully this can be resolved?

Since last note i have found the problem!

It is the power supply output, often after time (Heat)?

The original power supply was a 3A 36W

I have another WD HD (My Book World Edition) and it has a 4A 48W output.

I changed it over and all good!

I am waiting on a call from WD tech help to finalise the problem and RMA.

The Live Duo works fine except for a small password problem!

There are a few operation questions i have also.