My book libe 2tb wont boot up!

Hi, I ve been trying to boot my WD my book live 2TB for the last five days.

I tried reseting it … waited 1 day with it unpluged to cool off but nothing worked.
The led is blue and each five secs goes green them back to steady blue again.
I have to access my files.
can you help me ?

thanks for the help
best regards
bruno

I recommend you connect it wired to your computer. If it doesn’t work, you can try contacting support for assistance or to get this drive replaced.

Thank you Feragui !
Can you please show me how to connect it wired direct to the computer ?
Do I have to use a “cross” cable ?
It is necessary to change any network properties on my computer ?

thanks

It’s only possible if your computer has an Ethernet port available. Simply disconnect the MBL from the router, and connect it with an ethernet cable to the ethernet port on the computer. After that, it should give you a new IP address; if it doesn’t, try a 4 second reset on the back.

Thanks.
I ve tried that but the drive keeps its front led on steady blue with a short green flash each 8 secs.

Is there a simple, easy and safe way to get my data out of the Drive ?

thanks again