HELP -- Mybook Live 2TB fails to boot - blue, then red light

Hello,

I am hoping someone can help me with a problem im experiencing with my brand new 2TB mybook live.

The drive has been working flawlessly for 3 days, whilst I have been transferring my data to it.  After disconnecting the drive last night and reconnecting to my router, the drive will not boot.  

When its powered on, the blue LED will show for about 40 sec, then it will switch to red.  I can hear the drive spinning, but nothing shows up on the network.  I have tried different ethernet cables, different connections (ie. directlt to PC and Mac), reset, etc…all to no avail.

Has anybody experienced this issue, or know of a resolution?  I’ve spent quite some time googling and searching this forum, but have not found a resolution.  From what I can tell, I suspect the drive might be corrupted, but see no way of being able to restore to factory settings.

I was exceptionally happy with the NAS up until this…I cant believe it has failed after 3 days!!

Any help would be greatly appreciated.

Thanks,

Dylan

For all that you have already tried it seems to be your drive is defective.  Have you try connecting the drive to a different power outlet, directly to the wall?  I recommend you to contact WD support for assistance.

Hi Dylan.  Does this help any?

WD MBL User manual page 10.png