My Book External is not recognized by any of my computers and I can't find a driver for it anywhere

I have attempted to download a driver for my Mybook model # WD02500C032  but can’t find one.  I have been all over the western digital website.  I downloaded the data lifeguard diagnostic program and it picks up my other 2 WD external hard drives but not this one.  I have a lot of data on it that is irreplaceable and I need to access it in order to back it up-  Not sure what to do at this point.  Any help would be great-

1 Like

Ditto for me too.  This thing has not been plugged in since last time I used it . It has not been  bumped or moved. Only thing that has changed on my computers are windows updates. So maybe Microsoft has done something.

 I won’t toss this yet.  Lights up when I hook up any usb cable, shows up as unrecognized device in device manager on my windows xp pc, but not on my windows 7 machine.  But drive doesnt’ appear in my computer or in the wd diagnostic program. Tried various fixes out there but I see now this is a common unsolved problem lately with most all the old WD external drives, so I suspect a Windows update issue. I will patiently wait I guess.

What model name drive?

Mine is a WD5000EO32.    

   Upon further investigation it appears, based on the slight hum it makes, that possibly my last shut down was improper and  something might be stuck in the harddrive because it sat like that (albeit unplugged) for a month or more.

  I don’t think it can spin up, but i hear it trying every few seconds.  I threw it across the room so I’m looking for alternatives now.  I may go with one of those bricks you can easily put any drive in.

 Thanks for the response but I think it’s really broke now. It should be anyway, I threw it down pretty hard.

 Now that I hit the floor with it it still lights up when usb is connected, but still not recognized.

  Now it doesn’t even try to turn on…no noise at all.   You think it’s just a bad drive and is that worth replacing in this unit?   It’s a nice case for a hard drive!

Actually I might be on to something with the windows update thing. I just looked on my xp machine and a window had popped up telling me windows media player found a new portable device and did i want to deny or allow and what settings.

 I had went to playing with the laptop with Windows 7 64 and didn’t notice it yesterday.

  It’s possible windows media player had sorta taken command of the drive and so not recognized in windows explorer but seen by media player? I dunno because I ruined the drive by throwing it on the floor. **bleep**. Now I’ll never know.

I should add the new found “media player” portable device had the yellow triangle with the exclamation mark as part of its icon. So still probably couldn’t access. But it’s broke now anyway so darn.

actually i feel it vibrate a little every few seconds…can power supply be weak? Leds in circle work bright and I hear a little activity in the hard drive but it still doesnt sound like it even starts spinning.  What do you think? Ok now its quiet again…so sometimes it has a little activity on and off but no sign of it on my computer i hear a faint click about every second now…

Ok, wheres the edit function… anyway I just plugged in to my xp machine again and  notification of an unrecognized usb device just popped up…details say reconnect device because windo0ws doesnrt recognize because device has malfunctioned . It shows  a simple diagram of my four port hub and the unrecognized usb device on number three port.

Below that… recommended action is unplug and replug and if not working ,replace.

 So maybe I just have a bad  hard drive…sure didn’t get much use though…just old i guess.

Comments Please!

Do I need to just wait for a firmware fix or something?

:angry:I don’t know what was wrong with My Book. It looks like that My Book have same problem and no solution from the technicians.  I have the same problem. My J Drive is visible but won’t reconized by my computer. Does any one know the solution of how to fix this problem?


Try plugging it directly into pack of PC instead of the hub.

1 Like


Did you try different USB Ports? Where is the drive visable? The device manager? Disk Management? If it shows in disk mamagement go down on left where disks are named like Disk0 right click  there and see if it’s online.