My Book WD 2500 DO32 suddenly isn't recognized by computer - please help!


#1

Hi everyone,

I hope someone out there can help me with this or has experienced something similar and has some suggestions.

I have a My Book WD2500D032.  I’ve used it for about 3 years on both a desktop and laptop and it has been working with no problem.  Recently, whenever I connect it to my laptop via USB, it is not recognized at all.  The blue light in the front is on, which I guess means it’s getting power, but whereas when usually I plug it in, it revs up and an explore folders window pops up, the drive just sits idle and isn’t recognized by my laptop.  I’ve tried everything from unplugging it and disconnecting the power supply (which worked a couple times) but nothing now seems to be working.  I looked in device manager and it is not listed under the USB devices nor is it listed in disk manager as an external hard drive.

It’s worked on this laptop as recently as two nights ago but it just will not recognize at all. 

Does anyone have any suggestions on how to try to troubleshoot this?


#2

I have a similar problem (sounds like identical issues to the ones you are experiencing) with my WD5000D032.   My new Vista computer says there is a known compatibility issue with the drive.  It’s funny how MS knows this, but the WD people are of no help…Any luck finding any solution? 


#3

I too abruptly cannot access my WD5000DO32 after a couple years use on Vista. Also cannot reformat. Please let me know if any of you find a solution to reformat and restore drive.


#4

I have the WD5000D032 and it worked great on my XP system and this system that I bought a year ago. This system is vista home premium.  For some reason my system started slowing down, I suspected a virus or some such malady that may have contaminated the files. I worked feverishly to resolve the issues but was not able to remedy the problem. I was left with no other recourse but to restore my system. After the restore and hours spent updating I finally decided to connect the WD external. At this point I was prompted by windows to insert the startup disk so that the drivers could be loaded. I don’t recall a startup disk, I thought it installed automatically from the drive when I first connected to both computers.  The strangest thing is, is that I am able to use the drive through explorer but am continuously asked for the start up disk whenever I disconnect then reconnect or I reboot the system. I have located the file on the WD external and have tried to load the file which is located in the drivers folder. Windows is not recognizing it as the correct file.


#5

Same problem here!  Mine is…My Book WD 3200C032-002

I have had mine for close to five yrs worked like a charm, all of a sudden this prob started!  Shutting down and plugging and replugging is getting  tiresome already!  Sometimes I have to do this a few times before the drive will show up. If I get lucky enough for it to show up, it will go out at any given time, for sure if I shut down.  All I want to know is…is there a fix, or do I need to replace this external.  It won’t be another WD for sure!


#6

HELP!! my WD5000P032 doesn’t work neither…i need my files back! I hate WD now!


#7

I just got done buying a new external, I will NEVER have another WD, that’s for sure!  There certainly isn’t any help coming from their tech support!!  The more I read about this prob, with no kind of help, I decided I was not going to wait until my WD dies!  It really ■■■■■ that there are companys like this one, that don’t  acknowledge ongoing problems with their product and unhappy customers.  So long WD, you just lost another customer!


#8

i have the same issue with the wd drive 2500d032.  blue light was on but did not register.  Unplugged to different usb port and worked but then shut down to re route wires and now nothing.  the blue light does not come on and now its totally dead…do the ac adapters go bad …i hope WD reads this for I now need recovery .  i wiped my PC clean of docs for the fear of the PC going bad …Now i have regrets.