Urgent: Please help........Western Digital My Book WD4000C032 problem

Hi all,

I have a Western Digital My Book WD4000C032 which used to work some weeks ago but suddenly Windows XP has stopped detecting it. I tried all options but its still not getting detected. The green light at the front button of the HD is constantly on unlike earlier where it used to glow and stop.

I tried removing the actual harddisk from the enclosure and connected using  SATA to USB connector which i bought seperately. The USB got detected now and its showing up in device manager too but with 0GB. :frowning:

If i try to look up the device in my computer the external drive is not listed along with the other drives.

Kindly help if anyone has faced this issue or have any idea on the resolution.  Is it a firmware issue. I am pretty hopeful that the drive is working as it spins when connected and creates sound like it used to do earlier. Also i tried connecting it to different machines but no luck.



I have had the same problem just today.  Although I have not taken it out of its casing as I am sure that voids the warranty.  I have run “data lifeguard diagnostics” (that is the only place it shows up)  but all I get is the following message. 

Test Option: QUICK TEST
Model Number: WD 10EAVS External
Unit Serial Number: deleted
Firmware Number: 1.75
Capacity: 1000.20 GB
Test Result: FAIL
Test Error Code: 06-Quick Test on drive 2 did not complete! Status code = 06 (Failed servo and/or seek test element), Failure Checkpoint = 97 (Unknown Test) SMART self-test did not complete on drive 2!
Test Time: 07:19:16, November 27, 2010
Model Number: WD 10EAVS External
Unit Serial Number: deleted
Firmware Number: 1.75
Capacity: 1000.20 GB
Test Result: FAIL
Test Error Code: 08-Too many bad sectors detected.
Test Time: 07:28:45, November 27, 2010

I have no idea what to do now.  

I had the same problem with My 1.5 TB My Book. I found out upon looking at the USB connection was unsoldered from the little connection circuit board that connects to the hard drive via SATA. Now I don’t know if I voided the warranyty  by opening the enclosure. All I need is another mini USB to SATA connector and it has to be from WD, it must have SES drvers imbedded into the board connector. I took the connector off and installed it in via SATA cable and power cable and installed it in one of  the open bays in my computer and does not  recnize on my computer.Running Windows 7 ult. 64 bit and ran disk management and recognised disk and space but had to intialize it, I initialized it now its unallocted space but does not recgnize in my computer. Does anybody have a clue. I don’t wan’t  to format it because I have a lot of information and videos and may not solve the problem.

Your problem looks like mor bad sectors. I cant imagine of any other solution than formatting it. My drive is not even detected in the diagnostic tool. Windows detects it in device manager but nothing beyond that… :frowning:

Did you try other USB ports?  I’m also assuming that you’ve re-booted since the problem started.

I have a (similar?) problem with occasional “new hardware found” & a missing drive in \My Computer, instead of the usual list of drives (including my 0.5TB & 1TB USB external MyBooks). Twice it has just as spontaneously healed itself after a week or so (because I crossed my fingers?) as I requested an RMA.
You might try warm or cold re-boots with different ports.
You might look at your Windows Configuration Manager.
I never have figured what the lights mean. Sometimes steady, sometimes flicker, no apparent relation to activity or capacity.
I’ve given up trying to get WDAB to usefully backup a lot of critical information like email, bookmarks, installation settings, passwords, etc. in a way that is recoverable, so I just do a cascade file copy & exports.
Good luck
Backup & Security are a perpetual chore.


I have a my book essential and I cannot access to my Data : same problem 

Anyone have an Idea ?

Is it a good idea to open it and to connect it to a free sata port of my PC ?


First start a new thread this is an old one and they frequently start changing direction. Next how did you backup and what OS are you using. Have you tried other USB ports or cable? If this is a powered drive try a different receptable and turning plug 180 deg. It’s not a good idea to open up the drive it will void the warranty. Second there is a bridge board that uses hardware encryption and I believe a different number of pins.


1 Like