Music streaming issues / no thumbnails for photos via app and mycloud.com

Hi WD community,

I read quite a number of posts about MCM issues with music playback and missing photo thumbnails but never found a solution to my problems. I’d hoped the recent update might change things but it did not.
Any suggestions are highly appreciated. Thank you!

Music (access at home)

Music plays fine from devices connected directly (via DLAN/Devolo) to the My Cloud Mirror: Notebook, stereo and PS4. But as soon as I stream music from the MCM via WiFi/DLNA and smartphone/tablet to bluetooth speakers, stereo or any other media renderer, the problems kick in.

Almost every time, playback stops after three or four tracks. I hit play again, listen to some songs, music stops. And so on. And so annoying. Like Special Edition Greedo shooting first annoying. I tried several apps (e.g. MediaMonkey, BubbleUpnP, mconnect, WD MyCloud app) for Android and iOS - it’s always the same.

I tried several WiFi settings, the signal is stable. I also had this problem months ago when I still had another internet service provider.

Any idea what’s wrong or what I’m doing wrong? Do you think a static IP-adress would improve the situation?
Not sure if this will work with my router, though, which is a stripped down Technicolor 7200 (from Unitymedia, Germany).

Music (remote access)

I’d rather upset a Wookiee and have my arms pulled out of their sockets than using the WD My Cloud app to stream music to go. But I get I have to. I’d ignore the app’s lack of functions if it was actually working. But it never has for me.

It loses connection all the time, doesn’t play songs it did the other day and no matter if Android or iOS: After the device goes into lock screen, playback will stop at the end of the current song. The only ways to prevent this is skipping to the next track before the current song is finished or avoid a lock screen. Both’s not really an option. Has anyone found a method to stream music from the MCM without using the WD MyCloud app?

I had Phantom Menance high hopes for the new mycloud.com site but it`s rather underwhelming. You can do anything with your music files except listening to music. Well…that’s… Has anyone figured out a workaround? I don’t expect a Spotify/Rdio experience but I expect the possibility to listen to my music collection via browser.

Photos/pictures (remote access via apps and mycloud.com)

On all apps (WD My Cloud, WD Photos) for both Android and iOS I do not see any thumbnails. I reinstalled the apps, deleted caches, reindexed the MCM several times: no thumbnails. So the WD apps are as useful for me as the invention of the midi-chlorian count.

But showing pictures on a smartphone is no fun anyway so I had Phantom Menance high hopes for the new mycloud.com site but it`s rather underwhelming. You can do anything with your photos except for looking at them. Well…that’s… The mycloud.com site simply won’t open JPGs. Instead, I get a black screen and a “broken image” icon even though there is absolutely nothing wrong with the file(s). Temporary bug? Bad luck? I really appreciated to be able to access my MCM from a browser eventually. But if I always have to download the files before using them…come on WD.

Many thanks everyone

Hello there,

thanks for sharing you experience and i am sorry to hear what you had gone through with the app. Regarding the Static IP, you could try this to see if it helps you out with the music playback locally.

You can also try to do some port forwarding to see if it helps witht he remote playback, here is a link that might help you with this :

This thread might also be helpful for you:

Hope this helps you out a little bit with some of your issues, lets see if other users can share some more help and tips for you.

Hi ArMak,

Many thanks for your reply and sorry it took me so long to write back (had troubles logging in).

I’ll try the static IP and port forwarding and hope for a miracle even though I’ve almost given up the MCM. I still can’t believe it’s that inconvenient to stream music and that the mycloud.com site cannot display thumbnails and image files…

Hi, could you help with the following problem: I’ve copied a lot of music and photos to MCM 2gen and can see all the files througt WD app on apple devices and in local network BUT I don’t see most of these files on mycloud.com.
I’ve read that it could be cause of Twonky still scanning the media but 5 days of scanning seems to much