Multiple Issues, Various Lights

My 4TB MBLD shows a different problem/symptoms every time I check it.Here is a summary:
0 Totally unable to access dashboard by IP or name, two different computers, two different browsers.
0 The front light is sometimes solid/blinking green, sometimes hangs on solid yellow, sometimes no light at all, which then might later change to green or yellow on its own.
0 Network lights - bottom is solid green, top is blinking green for all conditions of the front light.
0 Can ping from PC and router when light is green
0 Sometimes unit shows in File Explorer Network by name, sometimes by IP, sometimes not at all, even when it pings OK. When it does show up sometimes the shares all show no files, sometimes the files are there.
0 Reset appears to have no effect, have tried pressing button for up to 1 minute, no reset, change in lights/drive noise, etc.
0 Smartware sees the drive sometimes, but won’t do backup, etc.
0 WD Discovery does not see the unit.
0 My Cloud on Android gives ‘Network Connection Failure’.
0 All above symptoms are the same when I connect the MBLD directly to a PC.

I don’t know much about how these units work, but it seems that the data might be OK but the unit/OS/etc. might be bad. I have it set up as JBOD. Maybe it is ‘Bricked’, but it does, sometimes, sort-of work. I gather from other posts that I can’t just get a MBLD without drives and move my drives into it.

I would appreciate any advice or ideas about how to proceed. I have a backup of the data so I can just get a new NAS and copy my backup over to it if that is best.

To be more clear, I think some of the symptoms are correlated to the front light state - for example, I think I can always ping when the light is green. Also, Smartware probably always connects when the light is green, but sometimes shows ‘no writable partition found’, but other times shows the shares with the correct amount of the share used.

Hello,

This may be caused by power, network or system issues. Here’s an article that might help:

Thanks for the reference. I have tried all of these alternatives with no joy.I guess I’m in for a new NAS.