Blinking green light. Can't access MBL

For 2 days now MBL NAS has been blinking green. I’ve tried resetting it by pulling the cord for several minutes and holding in the reset button on the back, but it still keeps blinking.

When i try to access the folder it says that the network path was not found.

I first google to see if I could find a solution. It seems that the blinking means that the HDD is writing data? I suspect it has something to do with a action the other day when I tried downloading a file to my android phone using WD’s app. MY mobile network was slow and the file was about 560MB so i gave up halfway. I think it went all wrong there.

I usually use WD quick view to connect to my MBL but it’s just gone.

Any help would be great. Not THAT technical so please have patience if I dont understand what your saying

I will meanwhile keep googling and fill you up to speed if I find a solution so that others can maybe learn from me

Can you connect to the dashboard?

What firmware revision does the drive have?

Try another port on the router and make sure to confirm if the drive is accessible on a different computer than the one you tested.