Movies not playing on Plex (not powerful enough)

Some movies play ok, but some don’t… I just get the loading symbol and nothing happens… I then went into ‘quality’ and went onto a lower one, and it worked, and then skipped to the middle of the movie and it said that the NAS wasn’t powerful enough…

So this is a MyCloud problem and not an internet problem? as speeds I get are 220 mpbs download, and 12 mbps upload.

The quality for the movies were all set on ‘original’ but i’m guessing this isn’t good enough as again, a lot of films aren’t playing, so what is a happy medium to play movies at on HD TVs with Plex that won’t lose noticeable quality?

Also why isn’t the MyCloud ‘NAS’ powerful enough? for example I have the movie ‘IT’ which I tried, and it wouldn’t work unless the quality was lowered, the file itself is 2.4GB, all of my movie files are between 1-4GB, most being between 1 - 2.50GB, is this the problem? as obviously Plex comes ready on the MyCloud, so surely if Plex is already available then the MyCloud should be powerful enough to play movies.

Can someone explain please.


The internet only comes into play if you are playing stuff on a device that isn’t on your local network (the same network as your MCH). At that time it’s your upload speed that is key (the 12 mbps), but if you’re on your local network then it’s just the throughput of your router and its connection to the device you’re using to play (presuming you’re cabled between the MCH and the router and both support gigabit ethernet).

But in the end the MCH is a NAS box, not a true media server. Yes it has had some capabilities given to it as a sales gimmick, but the processors and RAM in these devices are not optimised for media serving. Especially these home devices aren’t designed for “professional” quality.

From your figures it sounds like you’re trying to stream HD/Blu-ray rips maybe, which will put additional stress on the computational power. When you drop the quality you’re decreasing the effective file size that you’re trying to transmit, which is of course easier for the low power CPU in the NAS to achieve.

Personally speaking I gave up on all the “bells and whistles” stuff on my NAS (in my case an older MyCloud Mirror) such as Plex and even anti-virus scanning, and moved everything off to other devices (a Raspberry Pi3 is now my home Plex server) and just left the NAS to do it’s job of simply being a file repository without the overhead of analysing or transcoding.

Thanks a lot for the help…

We basically got the NAS so all our movie files can be on one drive, along with family photos/videos, so 3 of us in the house can view movies/videos/photos whenever we want on whatever we want, our Apple TVs, the Firestick or our phones/tablets, but it’s mostly the Apple TVs and Firestick… we did this as it was getting really annoying with us having our own external drives and having to keep unplugging and plugging them into my iMac and putting the same files on numerous drives, so the NAS seemed like the best option, and it has been good, but just having these issues.

Like I said before, when I lowered the quality for ‘IT’, it worked, it was all set on to ‘original’ for the quality, so is it best if I lower everything to a certain quality setting, and if so… what would be the best setting you recommend for viewing on 42-52" TVs? as at the moment I think I put it at 1080p at 10mbps, or is it best just to play something, if it works in original then it works, if not then just lower it bit by bit till it works? (im not that good with all of this sorry).

You posted in the My Cloud Home-Personal Cloud Storage sub-forum. Is that what you have?

Network Attached Storage sub-forums are here.

Sorry, i’m used to saying ‘NAS’ here as my family relate it to that and not their usual external HDs.

I have the WD My Cloud Home, single drive, 4TB, the one that’s white on top and grey on the bottom.

For the latter question, it would very much be a “try and see” scenario due to both the quality of the TV but more significantly how you personally perceive it. Also the quality of your actual media will have a part to play as well.

There are two factors here, both the media quality and also the playback capability/settings of the device. For example not all devices can play back all formats and resolutions, so the media may need to be transcoded from how it’s stored to a format that can be played. Doing that takes a lot more processing power than just serving up the file.

Also Plex isn’t the only solution to this. You could simply use your device as a file server and leave the playback to something local on the devices, such as Kodi or VLC for examples. That’s what I do at home, with my MCM providing files via NFS and SMB to my various Pi’s, PC’s and Android devices which each run Kodi to handle the playback itself.

My home has been working fine with my Samsung Blu-ray players Plex app, streaming 2-6gb 1080p movies no problem, are they mp4 h264?? Have seen some stuttering with avi files…h265 stutter too.

Have you tried Ethernet cable from router to player (maybe WiFi causing issue?)

Are you trying to transcode 4K movies? Don’t think single drive will do that…

Shouldn’t need to transcode - Instead of transcoding to 1080 10mp - try auto or reduce to 720…?

Hardware transcoding switched on in Plex??go to Plex settings>transcode>

Forget Plex; not good or versatile movie player. You have a Firestick, and play any movie file on it by installing an app from Amazon store called MrMC which is a derivative of Kodi app expressly for Fire TV. Use your Home as a movie server, not a player. I can play any movie file with this combo.

We kept with Plex as then it’s the same on all 3 TVs (2 Apple TVs and Firestick), as there are family photos and home videos on Plex too, so it’s easier for us to use the same thing… instead of the 2 Apple TVs using Plex and then one using something else.

Also the 2 Apple TVs are connected via ethernet, same as the WD MyCloud Home, obviously the Firestick not having that option so that’s wifi but that one is right next to the router anyway.

and no, no 4K movies, they are all 1080p, I don’t pay for the Plex pass, I did have a month and didn’t have problems but believe that month is now over, maybe that’s why i’m getting issues now?