MKV playback broken after few minutes


Yesterday I got my WD TV Live HD and I tried to play a few mkv movies but I was disappointed to see that after a few minutes of playback the video goes broken and audio is lost. The problem occured in all files I tried, and I have seen these file playing without a flaw in other media player (including the older WD TV HD).

I read in forums that other people have the same problem too, and it was suggested to downgrade to an older firmware or re-installing the latest firmware from the Internet.

I tried both installing an older firmware (1.01.24) and after that re-installing the current stable firmware (1.02.21) but the problem persisted in both firmwares.

Can you please advise what to try next?

You could post the mediainfo on one of these files. Also how are you playing these files, is it via a connected drive or a network. Have you seen all of these files played by a WDTV?

I play the files from a USB connected WD Passport (~540GB).

Here is the mediainfo for two of the files I used.

Any ideas please?

[update] Yes I have tested this files on an A.C.Ryan player and a WD TV HD (Gen2) they played nicely.

Can you try with a different drive?  The files look okay (and playing them on another WD player seems to prove that) so I’d want to isolate the drive from the picture (even if the drive works on other players, as the Live IS sensitive to different drives).

Using a flash drive would be ideal – otherwise I’d reformat the drive and copy only a file or two on it (because it can also be related to too many files on that drive and WD trying to build a library).

You could always ask Amiable for your money back.